Utorrent not allowed

(:SAD)I started to use comodo and had no problems then I upgraded to comodo pro ,it would not allow utorrent port to open even though i put it to allow trusted site and have a 100% utorrent.exe traffic …What have I done wrong… (B)

Greetings!

Now I don’t quite rememeber how the rule set for 2.4 should look, but I think this is right:

Run uTorrent, and in Options->Preference->Connections
uncheck Random port each time utorrent starts, I guess you’ve choosen a port for incoming connections, let’s use port 1234 as an example.

Add Network rule for utorrent (destination port is your listening port), and place it at the top of the other rules (this is important!):

Action: Allow
Direction: In
Protocol: TCP or UDP
Destination Port: 1234

Here’s what uTorrent’s application rules should look like:

Action: Allow
Direction: In
Protocol: TCP or UDP
Destination Port: 1234

Action: Allow
Direction: Out
Protocol: TCP or UDP

Run utorrent, go to Options->Speed Guide and click Test if port is forwarded properly to see if it’s done right.

Also, if you’re using a router, you’ll need to configure it for port forwarding (Port Forwarding Your Router to Get Open Ports).

  1. Choose your router model (if it’s not in the list, choose one from the same company)
  2. Select the software (in this case, uTorrent)
  3. Now follow the steps in the guide

I hope I got it right now :o

Cheers,
Ragwing

Merry Xmas
Sorry ragwing , u have lost me
(Add Network rule for utorrent (destination port is your listening port), and place it at the top of the other rules (this is important!):slight_smile:
has this to be put in comodo pro and if right how do u do it? because my port number is there as a listen port but when i go into utorrent and test my port it say error port seems to be not open
My router bt home hub has been forwarded
How can I turn off comodo and just try my windows firewall and see if I can open it through that
Thanks

I have an identical problem despite forwarding the port 6681 correctly.
Even though u-torrent.exe is allowed over the full port range in the firewall application monitor the u-torrent icon is always yellow or red. Only when I disable the firewall does it go green.
Look at your activity logs and you will probably see an inbound policy violation on your port.
Sorry this is not a fix but you are not alone. If you are behind a router you should be safe to turn off the firewall while using u-torrent. Forget about the windows firewall.
If a fix is posted I want to know too. :-\

??? still waiting for some help (:WAV)

Try this -

https://forums.comodo.com/help_for_v2/help_getting_comodo_to_allow_utorrent_resolved-t8049.0.htm

Works for me! Good luck.