Using SoundBridge & Firefly music server [Closed]

hi all,

My Soudbridge-device can’t connect to the Firefly musicserver when the firewall is running.
Does anyone know how to set a rule to allow this?
Someone on the Soundbridge forum suggested that multicast is being blocked ?!

thanks
mr.shaky

Does the firewall log show anything as being blocked?

Activity>Logs

jasper

hi jasper,

here’s some of it :

Date/Time :2007-05-03 20:31:36
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 192.168.1.10, Port = upnp-mcast(1900))
Protocol: UDP Incoming
Source: 192.168.1.10:1555
Destination: 239.255.255.250:upnp-mcast(1900)
Reason: Network Control Rule ID = 8

Date/Time :2007-05-03 20:31:36
Severity :Medium
Reporter :Network Monitor
Description:Inbound Policy Violation (Access Denied, ICMP = PORT UNREACHABLE)
Protocol:ICMP Incoming
Source: 213.171.61.131
Destination: 192.168.1.11
Message: PORT UNREACHABLE
Reason: Network Control Rule ID = 8

The source-port seems to be changing all the time.

cheers.

Nothing in the log you posted looks suspicious yet.

First of all let’s find out which part of the firewall is doing the blocking.

Go down to your firewall icon in the system tray and right-click it and set it to “Allow All”
Now try connecting to your server again.

This should let us know if it is a rule doing the blocking or not.

jasper

Yep … that works!

Now let’s see if we can get the log to show us the problem.

Reset the firewall system tray icon to “Custom” again

Go to the log and right-click anywhere in the window, select to clear it, then try to connect again.
Leave the log window up as you will be saving it next.

Once you have tried to connect again then right-click in the log window and choose “Export HTML” and save the file where you can find it.

Ok, when you post back here upload the html log file that you saved by clicking on “Additional Options” just below the text window.

Maybe something will show up in that log to lead us to what is causing the blockage.

jasper

P.S. You might want to block out your IP address before you post it here. If it a NAT (192.168.x.x) address then we all have those IP’s so that should be ok.

Ok … made it a txt file 'cause last time I got a “can’t upload html” message.

[attachment deleted by admin]

OK, before we start making rules from the log, I just went to the web page for Southbridge and it says that you have to set the communication port within the software itself. Have you done that?

According to them all you have to do is set the port, allow firefly.exe, and then set up a rule in the firewall to allow that port and it should work.

jasper

Don’t get that last bit.
The Soundbridge Radio connects to the internet thru wifi and this works fine.
I’m now trying to play the music files on my computer via the Firefly musicserver.
It took me a while to get Windows to see the device in Network Locations (pardon my english, I’m translating from dutch).
I uploaded the “network control rule” that worked.
So the connection is good, but the firewall blocks it.

[attachment deleted by admin]

Ok, went back and read some more on the setup. The firewall port is for the MacOS only it says. Sorry misread it.

Make this rule at the top of your list:

ALLOW-check the checkbox
UDP
IN
Source IP: 192.168.1.10
Destination IP: ANY
Source Port: ANY
Destination Port: ANY

Once you write the rule go to the system tray icon and right-click it again and set it to allow all then back to custom. This should refresh the rules. If it doesn’t refresh you might have to restart the computer.

Clear the log and try to connect again then check the log for any blocked entries.

jasper

No connection.
Here’s the log.

[attachment deleted by admin]

Change the rule to “TCP or UDP” and try it again.

jasper

Still no go.

Jasper,

Have to sign of.
I’ll check back here tomorrow evening.
Thanks a million man for your help so far.
Realy appreciate it.

greetings
mr.shaky

Ok, sorry I couldn’t get you up and running.

Figured it would pop-up and ask you to allow firefly.exe on that one.

Anyone else got any ideas jump in. Was gonna start turning off modules on the firewall next if something didn’t show up in the log.

jasper

mr.shaky,

Please do the following to help us help you here…

Open your Network Monitor to full-screen size. Capture a screenshot and save it as an image file (.jpg, .png, or .gif format). Attach it to your next post using the bold red “Additional Options” under the text box.

Also please do this as well…

Go to Activity/Logs. Right-click an entry and select “Clear all logs.” (make sure to clear those out; I want to be sure we don’t add on top of old entries) Then try to connect to SoundBridge/Firefly/etc (do this action and no other). When it fails, go back to Activity/Logs. Right-click and select “Export to HTML.” Save the file.

Then reopen it, highlight the entries, right-click and Copy. Then Paste that into your next post (don’t try to attach, just paste it in). As Jasper noted, if your external IP shows up in the logs (it will match the IP showing in the bottom right corner of your posts), you can mask it with “x”.

Then we’ll match up the log with your network rules. BTW, I know Jasper had you do this before; I just wanted to take a little different approach, with repeating it.

LM

PS: Jasper, he didn’t get a popup because it’s not an application issue - it’s a network issue (ie, the type of traffic)

hi Little Mac,

well I’m stunned !
This evening I turned everything on, and at first the Soundbridge device could’nt see any servers on the pc. I changed the firewall setting to “Allow all”, turned Soundbridge on & off a couple of times until it finaly did. So I changed the setting of the firewall back to “custom” and the ■■■■ thing kept on going. To check I restarted the computer & Soundbridge once more … still working !!!
If you ask me, the Soundbridge device is a bit, shall we say, unstable.
Anyway, thanks for your time.
I think Comodo is great!

greetings
mr.shaky

Well, I was wondering about that. I went back to the documentation yesterday and it mentions a different protocol that is used. I just figured that Upnp would be how it communicates and that the protocol used was somehow part of Upnp.

One thing I was curious about mr.shaky, is the 192.168.1.10 address the address assigned to your PC or is it assigned to the Southbridge? One thing that makes me ask this is that there was also a 192.168.1.11 address in the log.

Just trying to figure out how it is connecting for future FAQ.

Glad you got it working though and thanks for the help LM. Enjoy!!

jasper

I’m glad it’s working for you, mr.shaky. However, I have doubts it will continue to do so.

Reason being is, it was being blocked by CFP’s Network Monitor. This means that the type of traffic it’s generating/trying to use is not allowed by the existent rules. It won’t just start working by “magic.” If you did not make any changes to rules in CFP’s Network Monitor, that means soundbridge must have changed its protocols and is now within the guidelines of your existent rules. Thus, my conclusion would be that it will change again at some point, and leave you stranded once more.

Since it’s working, there’s not much we can do to diagnose a nonexistent problem, LOL. So I’ll mark the thread as closed. If the problem does reoccur, just PM a Moderator (include a link to this thread) and we’ll reopen it for you, so we can readdress the issue.

LM