Using AVG8 free with comodo firewall


I have recently upgarded from avg7.5 to avg8free and have been unable to get updates for the program. With 7.5 the file was avginet.exe. I am unable to find an equivalent with the avg8 free. Does anyone know how to get the updates working with the comodo firewall for avg 8 free?


Try putting D+ in training mode for a day or so. You can also change AVG to update at a time where you are going to be near your pc and when Comodo gives a a pop up then click allow. I had to that years ago. BTW your better off with Avast. AVG has no web scanner.



I had version When I tried to update the software it came up with error 106 could not complete update process. I then un installed comodo 2.4 and downloaded
the new version and immediately avg8 updated. It would appear there was a pproblewm with my old version of comodo firewall 2.4.

Thanks for the prompt asking about the version I was using. This prompted me to attempt an update which disclosed the problem


No. That was expected. v3 compared to v2 is like:

Egemen = CFP lead developer. The differences are too great to auto-update, so there is no choice but to uninstall 2.x in order to install 3.x .

Anyway, you can try V’s suggestion and report back.

In AVG8 it is avgupd.exe that is the updater.

I also have this same problem, but I can say that when using AVG7.5 and Comodo v3, I could update just fine. After upgrading to AVG8 I have not been able to update at all. I have Vista without the sp1 (I think that might have been the start of the problem when I tried to install it… That’s another story) AVG8 (8.0.93 with the virus DB 269.22.4/1355) and Comodo My internet connection is either WIFI through a hot spot or dial-up. Nether will update. I don’t seem to have a problem updating any other programs… Please help! AVG can’t.


Have you tried the suggestions above at all?

Yes, but I think I started from a different place. I was using comodo v3 and avg7.5 and everything worked just fine. After installing AVG8 I could not update. I uninstalled AVG and reinstalled with the same results. I think that I have upgraded Comodo once and that did not change the symptoms.


So glad this topic has come up - as a first time user,

  1. I’ve just switched my old laptop which is now running AVG 7.5, from ZoneAlarm to Comodo 3. I understand C3 has Defender+ fighting malware, etc. But the new AVG 8 also fights malware. I also run MS’s Windows Defender which fights malware. Are all these real time malware fighters going to trip over each other and cause trouble?

  2. My new laptop is now running Norton AV 2008 which fights malware real time but does not have a firewall. I have been relying on Windows Defender and its inbound firewall and the Norton system which has some kind of outbound protection. I’ve never run any other firewall with Norton but would also be interested in compatibility of Comodo 3 with the Norton AV.

Thanks for advice.

You try 2 things One find out which exe file is the updater. You can this by simple trial and error. Go into the AVG folder and execute the file in there. See if one generates D+. If you mouse over each one it will tell you what it is. Secondly you can put D+ training mode for a day or so then put it back. Last is to change the time AVG updates to a current time like 10 from now. When AVG updates you will most likely get a D+ alert. If you do make that an updater.

You can also check the CFP log to see if anything from AVG is being blocked. There are many ways reach the log screen, so I’ll give one e.g.:

Firewall > Common Tasks > View Firewall Events > More… button

I installed AVG 8 about a week ago and it would not update. AVG 7.5 had been working fine.
When clicking the Updatie now button, I got a message saying the update failed because server disconnected.
I am not using the comodo firewall but this might help:
I ran winsockfix and had it fix the problems it found. Auto update and Update now immediately started working and now seems to be fine.
Do a web search for winsockfix or get it from [].
Good luck,


Welcome to the forum, Boonchuy, and thanks for the tip.

I look for this and found that it was for XP and it is no longer supported or developed. Are you using XP or Vista? Have you run it for Vista?


From M$ themselves:

This applies to both XP & Vista:
Start > Run > netsh winsock reset > reboot