Use Proxy Server for your LAN keeps setting itself as default

I’m having a problem where Comodo Dragon keeps defaulting to using a proxy server. The result is that I can’t connect to any web sites.

I have to go into the proxy settings and uncheck the “Use Proxy server for your LAN” box and then the websites can all connect again.

I don’t know why it’s doing this. I tried unchecking both proxy boxes. I tried checking the “Automatically detect settings” box. Eventually it will change back to “Use proxy server” again.

Sometimes it remains normal and automatically detects settings for a few days or a week or two. Other times like today it switches back to “use a proxy server” several times in one day.

I DO NOT use a proxy server to connect to the internet.

Chrome seems to have this problem, but I wanted to see if anyone could solve it here.