usb mouse not connecting consistantly after restart once Comodo Firewall install

Hello,

I recently rebuilt my wife’s computer using Windows 7. I’ve been installing apps and testing functionality as I’ve gone along. This evening, I installed Comodo Firewall and set up the configuration as recommended on the following site:

http://www.techsupportalert.com/content/how-install-comodo-firewall.htm

except that I did not disable HIPS.

Now, each time I reboot the system, the usb mouse connects about 50% of the time. When it does not, I can often unplug it for a moment and replug to establish connectivity.

I would greatly appreciate any insight to help resolve this.

Thanks in advance!

Please post a screenshot of the files in the Unrecognized Files List.
Also, post a screenshot of your Defense+ rules for applications?

Thanks.

Thanks Chiron,

I’ve attached the requested screenshots.

[attachment deleted by admin]

Please try disabling the HIPS component and see if the problem continues. This is not a solution, but should provide us with more information from which we can construct a solution.

Also, does the mouse have any application which was installed to control/configure it?

I disabled HIPS and restarted 4 times. The first 2 times, the mouse connected. The next 2 it did not.

I have not installed any applications for the mouse.

I suppose this could be a coincidence, or due to the driver.

Have you tried updating the driver for the mouse?

Also, do you have another mouse you could try?

Please uninstall the mouse driver in Device Manager, disconnect the mouse and reconnect it. Windows should now detect it and install the driver for the mouse. Does that help?

Sorry for the delay. I was away this weekend.

I do have an small PS-2 mouse that I used to use with my laptop years ago. I could see if that works, but I wouldn’t want that as a long term solution. Would trying it tell us something?

I could uninstall the driver and let Windows re-install, but I don’t understand why that would be any different than what I have now. I didn’t install any drivers specific to the mouse and let Windows install whatever driver it wanted originally when I started setting up the system last week.

I’m reasonably confident the mouse was working fine prior to installing Comodo Firewall as I was testing along the way and restarted the system many times. Understanding this, if the feeling is that I should still let Windows re-install, I’m open to give that a try.

Yes.

If this is an issue with the driver this may be able to fix it. It’s worth trying.

Here’s what I did and what I saw.

In the Driver Manager under Mice and other pointing devices, I saw 2 identical drives called HID-compliant mouse. I uninstalled both, unplugged my USB mouse, plugged in my PS-2 mouse, and restarted the system. Once it came back up, the PS-2 mouse functioned properly. I looked at the drivers and saw one instance of the HID-compliant mouse driver had re-appeared and I had a PS-2 driver. I uninstalled the HID-compliant mouse driver again and restarted again. Once again it reappeared. The PS-2 mouse functioned properly.

I then proceeded to reboot the system at least 6 more times with the mouse working each time.

I then unplugged the PS-2 mouse and connected the USB mouse. It functioned properly.

I then restarted and the USB mouse did not function upon startup. I unplugged it for 10 to 15 seconds, plugged it back in, and it functioned. I looked at the drivers and once again saw 2 instances of the HID-compliant mouse drivers.

Thoughts?

Hi ansley,
Do any of the suggestions in the outside links below help?
USB Device Not Recognized on Windows 7
USB Mouse stopped working
Laptop USB mouse stopped working

A couple of questions for analytical clarity. The PS2 mouse you are using is being hooked up to a PS2 port or is it hooked up to a USB port using a PS2 to USB adapter? Your USB mouse is hooked to a USB port. Is that correct?

That is correct. The PS2 mouse is connected directly to a PS2 port and the USB mouse is connected directly to a USB port.

I also have a USB keyboard connected to a USB port which is working just fine. Same for printer.

I’m reading through the links provided by captainsticks, but I’ve not finished.

Keep us posted.

I’ve now read through all 3 of the links provided by captainsticks. The prevailing suggestion is to shut down the system, turn off the power supply (this system is a desktop, so unplugging the battery isn’t meaningful) for 5 to 15 minutes (I shut it down for over an hour), and then restart. This did not correct the problem. Another suggestion was to go into the device manager, scroll down to the USB controllers, select to show the USB Root Hubs, right click and select Properties, choose Power Management tab, and uncheck the box for “Allow the computer to turn off the device to save power”. I tried this as well with no luck.

Appreciate that I’m not getting a “Device not recognized” or any other error message as mentioned in these posts. The mouse has an illuminated wheel which lights up when it is functioning properly. Each time the system reboots, the light comes on near the end of POST and up until “Windows is Starting” (about 5 seconds. It then goes out while Windows continues to launch. When is connects successfully, the light comes back on right before the user log in screen shows up. When it does not, it flickers faintly for a few seconds and then goes out.

Can you check the Windows logs in Event Viewer (Control Panel → Administrative Tools) and the D+ logs to see if they are reporting something concerning the mouse or the installation of related service or driver?

When they don’t give us anymore clues I am calling this a bug.

Hello EricJH,

I’ve spent a couple hours poking around in log files, but I’m not sure I’m looking in the right place or know what I’m looking for.

I first opened the reviewed the Windows logs by bringing up the Event Viewer, selecting one at a time each of the 5 items under Windows Logs, and searching for various terms such as usb, mouse, and comodo. I got numerous hits for each, but it wasn’t clear to me that any of them were indicating a problem.

I then brought up Comodo, selected General Tasks, and then View Logs. For Show, I selected Defense+ Events and scrolled though the very long list as I could find no means to search the list. Again, there were several lines that included usb and/or mouse, but under Flags, indicated Scanned and Found Safe.

Is this what you had in mind?

When browsing the Windows and D+ logs focus on the moment(s) where the mouse was detected and see what both report. In the Windows logs look for everything around that time with an yellow triangle or red circle and when they are there see what they report and whether the error could be related.

Can you post a screenshot of the D+ logs of around the time the mouse gets detected and driver installed and the mouse is not working?