URGENT !!!

right from winxp to any firewall i tried in the past all the ports were stealthed when checked with grc.com. but from 2 days none of the ports are stealthed. all the ports are closed and ports 21,53,80,199 and 443 are open. i tried winxp, comodo, online armor, zonealarm and pctools but the same results. all the ports closed and the above 5 ports open. scanned the pc with comodo, avast, avira, superantispyware, malwarebytes, a squared and hitman pro but no malware found. your help needed.

thanks
naren

When using Comodo, did you go to the Stealth Ports Wizard and choose the last option; “Block all incoming connections?”

yes i did that and checked the global rules too.

are you behind a router with a hardware firewall enabled?

no router. i dont know if this will help or not. for few days like 2 weeks i used xp firewall then before installing zonealarm free i restored the xp firewall to default and disabled it. one more thing. to connect to the net i have an icon on the desktop. i have to double click it and fill the username and password and click on connect. the service provider has given me an ip address to check my account status i.e in internet explorer i have to enter the ip address and hit enter and their site opens. there with username and password i can check my internet usage. what i want to say is that i dont know what they have changed but they have now given me another ip address to check my internet usage and this was 2 days before and from that day only i m having this stealth problem. is this of any help??

thanxx
naren

This could be your ISP which is using a proxy to block/open certain ports. What is your ISP? Maybe do a bit of googling to see if they do any port blocking.

Are you sure that information for that “new server” came from you provider?
Did you get it by email?

my isp name is nivyahbroadband. in grc.com it appears as dynamic-mumbai.nivyah.com. i had called the isp and he gave me the new ip address.

thanxx
naren

Can you verify if you have even port 21 listening on your system?

You can verify this by opening a command box (Start, Run cmd [ENTER])
You’ll get a black window now type the following command in there

netstat -an|find /i “:21”

This should normally turn up empty on a normal PC cause it doesn’t run FTP Server standard.
You can also try

netstat -an

To see all output from that command…

netstat -an|find /i “:21”
i copy-pasted this and that documents and settings appears again

You mean the command came up empty? and returned to c:.…> again?
Like the 21 example here, if you try the same with 135 do you get the output as shown?


c:\>netstat -an|find /i ":21"

c:\>netstat -an|find /i ":135"
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
c:\>

yes

any help and info here plzz??

Well if you PC doesn’t show 21 listening and GRC reports it open, there is a big chance your scanning an other system then your PC that is in between GRC and you.

Does the IP address GRC shows match your IP address on the TCP/IP Stack?
You can retrieve your IP by using the command-box and type:

ipconfig

And verify the number with the one GRC shows on their site…

no the ip address grc shows does not match. grc shows the new ip address the isp has given me but ipconfig shows the old ip address that grc use to show before the new ip address.

one thing more. first when i use to check with grc the last digits of ip address use to change everytime. but now everytime its the same ip address and no change.

Then your probably browsing true a Transparent proxy your provider is using.
Is you IP address a public or private range one?

Privates are normally in 10.x 172.16-31 and 192.168.

ipconfig -

ethernet adapter local area connection 3
ip address 192.168

ppp adapter connection to nivyahbroadband
ip address 183.87

So your provider has an “internet network” based on public IP’s.
But if you browse to the internet you go trough a Transparent proxy causing GRC to scan that system and not yours, so the test results are not reliable for your machine.

The changing of IP on your PC has to do with your provider using DHCP to assign a number to you.
On your new PPP Settings they have set a fixed address probably.

Does one of your friends have the same Provider? maybe he can run a scan tool against your PPP IP to see if your stealth or not

you said on my new ppp settings they have set a fixed address probably. so why this new address is not showing in ipconfig instead of the old address.

in my building there are 2-3 people using the same provider. but i dont know how to check if my system is stealth or not from their systems

Okay probably some misunderstanding here, then it looks like they have fixed your latest IP?
Any way you can’t use GRC to determine if your stealth or not, but are also not directly connected to the internet so there is some form of firewalling done on the ISP side.

To scan your system from an other system within the same provider you can first try to “ping” your IP from the other system, and see if that IP shows up in your firewall logs as blocked.