Urgent: CPF makes internet access unusable!

Some time ago I noticed that if I leave Shareaza running for a day or so, I can no longer connect to the internet from any other application.

IE, OE, and every other application that tries to open a TCP connection, just sits there with the connection in a SYN_SENT state.

At first, I thought it was Shareaza’s fault but today I tried turning CPF off and presto! everything works. Turned CPF back on and no more new connections.

This makes CPF completely unusable for me.

Please advise.

CPF version
Application Behavior Analysys turned off
OS: Win XP pro SP2 with latest updates and the “half open connections” increased to 500 via patch.

Just to clarify, is this the patch you’re referring to? SG :: Windows XP SP2 tcpip.sys connection limit patch


I have no experience of these p2p applications but I am wondering if your problem may be caused by CFP thinking it is detecting a DOS attack. Have you tried modifying the advanced intrusion detection settings for CFP?


Hmmm, could be. Good idea.

  • How do I find out if the Intrusion Detection was triggered?
  • What settings are suitable for P2P? Or how do I turn it off?

I dont know how you would know if it was triggered as it has never happened to me but I assume the symptoms would be similar to what you describe, I would expect something in the logs but not sure - perhaps someone may post here who has experienced this.

With regard to settings, I think that may be trial and error with the settings shown in the attached screenshot. I would increase the numbers step by step (maybe double them initailly) until everything works.


[attachment deleted by admin]

I raised the traffic rate of both TCP and UDP to 500 packets/second but it did not help.