UPSDbMaker.exe ---> Buffer overrun error when scanning.

I have posted my problem here earlier this week, in this forum:,8776.0.html and decided post to the BETA corner as my problem may be peculiar to the BETA.

After searching further, I found this post: Comodo Forum

…BUT, when I look at the error log, there is nothing in the file except the date and time of the crash. (In SETTINGS/REPORTS/TROUBLESHOOT, I have Create Troubleshoot Log checked). I have attached the file and log files for your review.

I have not been able to complete a User’s Profile scan since installing the program without getting an error. Last night, I re-installed Comodo AV, then re-installed to see if I had a corrupted file somewhere.

Would love to hear some feedback.



[attachment deleted by admin]

When I started CAVS ( the User's Profiling Dialog box pops up. I choose to let it scan. After a while, an error dialogue box pops-up with the following message:

Microsoft Visual C++ Runtime Library

Program: c:\program files\Comodo\Comodo Antivirus\UPSDBMaker.exe

A buffer overrun has been detected which has corrupted the program’s internal state. The program cannot safely continue execution and must be terminated.

Any advice on this one?

Regards, Nanook1963

Welcome Nanook1963 ~

I’ve quoted your original post here, and removed the other, to combine for simplicity.

Thanks for the troubleshoot logs; hopefully that will be of use to the dev team. They may have need of some others as well; if so, they will let you know.

As a question, did you have any other active/real-time security apps (like an AV, HIPS, antispyware, etc) running when you installed CAVS?


I was running BOClean (most recent version) and Comodo Firewall Pro at the time of installation.

Windows Firewall is/was disabled, and I had uninstalled NAV2007 and disabled Acronis Malware Shield before installing Comodo Antivirus. Hope this helps.



That should rule out a conflict with other security apps, during the install process. Since such things are known to cause problems in general, it’s good to get that out of the way.

Now we’ll have to wait to see what the dev team needs (if anything) to find out what has occurred.


I have run into the exact same error reported in this thread. Every time I booted after installing CAVS, I would get the “User’s Profiling Dialog” and I would initiate a scan. And each time, it would fail while scanning the same file (a .jpg file in my IE cache).

After the third time and my realizing that it was happening on the same file, I went into my cache and deleted that file (along with some other useless junk in the cache). And that solved the problem! I have just completed a full scan without further incedent.

So, there is definitely a buffer overrun bug in UPSDBMaker.exe and it seems to happen with certain files (perhaps .jpg specific?). Sorry that I didn’t save the file before deleting it so it could be analyzed. But I bet I could find it in a backup (yes, I do backup faithfully) if someone really wanted to analyze it. Just let me know. Before deleting it, I did open the file that was causing the problem and it opened fine and looked like a normal, small (180 x 180) picture.

Umesh has a post in this thread, with an attached zip archive - it contains files to replace, and he gives instructions on the usage thereof. It should help.