Uploading no longer works...[RESOLVED (Re-installed CFP; uninstalled KAV =D)]

Okay, I’m a Comodo - and indeed a firewall - newbie.

I’ve been having problems with uploading recently which may have something to do with my shiny new firewall. All upload sites (ie. Megaupoad, Photobucket, Bebo (!), and even Livejournal) don’t upload at all. Firefox sticks at "sending request to x_or_y.com

Now, this may be all to do with something else, because when I switch Comodo to “allow all”, these problems still occur.

I’d upload a picture of my Network Control Rules, but I can’t get a screen capture onto the net… If you really need them to assess the problem, I’ll type them up. But only if I have to =P =D

Thanks for your help.

Hi Kryters

It’s possible something is getting ‘blocked’ somewhere. Open CFP then the Activity tab/Logs. Right click anywhere in the Log window, select ‘Log Events From’ Make sure all four options are ticked. Next, select ‘Clear all Logs’ from the same menu.

Now try to upload and see if anything is captured in the Logs. To make it easier to read, you can export the logs to HTML, same menu as above.

Also check Application Monitor, Component Monitor and Network Monitor for any ‘Block’ rules.


Okay, my network control rules are a little over-zealous.
Number 7 blocks and logs TCP/UDP in from [any] source to [any] destination where source port is [any] and destination port is any.

Alas, I’m not sure this is the problem, as I am getting no logs when I try to upload. Everything in app monitor and component monitor is set to ‘allow’ right now.

And now to compound matters, my Windows Live Messenger is playing up. Apparently there’s a problem on my side of the connection… This seems to be down to Comodo, but I can’t for the life of me figure out why and how to fix it…

Thanks again.

In Network Monitor, open each Block rule to Edit it. Make sure the box, “create an alert if this rule is fired” is checked, then click OK. When you’re finished making those changes to each Block rule you have, Exit the firewall from the systray icon, then restart it (or just reboot computer).

Then see if you get any log entries.


Yes, I have already ticked that box. That’s why I’m so puzzled. These problems only started occurring just after I installed the firewall, yet there’s no clues as to why it is playing up =P

Should I just get rid of all these network rules in favour of more lenient ones.

Blocks and logs TCP/UDP in from [any] source to [any] destination where source port is [any] and destination port is [any] is the only “block” rule I have on the list. Above it there are six “allows” for various things.

Any suggestions. This is really starting to get to me… Grr =D

Here’s what I’m thinking may be going on. If you’ve, uh, “improved” :wink: the default network rules (which it sounds like you’ve been working on), you may not be explicitly allowing the type of outbound connection you need to do the uploads. There is a reason the default Block rule is In/Out rather than just In. Here’s a way we can define it:

Go to the bottom Block rule that you have. Right-click, select Add/Add Before. Create this rule:

Action: Block & Log
Protocol: IP
Direction: Out
Source: Any
Destination: Any
IP Details: Any


Now this gives you a separate rule (I prefer separate, not combined) rule to block & log any traffic that is not explicitly or implicitly allowed prior to that rule in the flow down thru the rules. This may give us an entry in the logs. Here’s what I’m thinking you may have - if you have very tight rules to allow only certain protocols/ports/ip address combinations, the upload may not be explicitly (by a specific rule) or implicitly (by a general rule); however, since there is no dedicated “block” rule, rather than being explicitly blocked (by a “block” rule), it’s being implicitly blocked (since it wasn’t allowed) and so it’s not getting anywhere. However, since there’s no “rule” being broken, there’s no log entry…

It may also be helpful if you will open your Network Monitor to full screen size. Capture a screenshot, save it as an image file (jpg, png, gif). Attach to your post under “Additional Options.”

If you get entries in your logs now, please do the following:

Right-click an entry, select “Export to HTML.” Save and reopen the file. Highlight the entries. Right-click and Copy the highlighted area. Paste it into your next post. If your private/external IP address shows in there (it will match what you see on the bottom right corner of your posts here in the forum), you may mask it out with “x” for privacy.


Here’s the deal. I found this Comodo network rules tutorial somewhere on the internet (before discovering the forums, of course) and decided the follow their advice. Now, maybe I misunderstood something about the instructions and implemented them wrongly. So I’m not in any way emotionally attached to this set of rules ;D

I just want a general set of rules which are efficient. Any links to where you can provide this? =D

The weird thing is that these problems still occur when I completely shut Comodo down. Is this normal behaviour. Is it even Comodo at all? I kind of hope so…Or else I have something seriously wrong.

Anyway, I’m in a bit of a catch-22 here - I can’t upload photos at all. I already have a nice screenshot of these rules, but I can’t actually send them as there is no place to put them. =O

Plus, I’ve visited a load of ‘problem sites’ and no logs as of yet.

I’m gazzumped. HELP! ???

:smiley: Thanks again.

Hi Kryters

Did you have a firewall installed prior to using CFP, if so which one? Also, do you have the Windows firewall enabled?

Some links to building rules:

All the FAQ entries:
FAQ for Comodo Firewall

** FAQs/Threads - Read Me First **

Understanding Network rules:
How To - Understanding & Creating Network Control Rules properly


No firewall prior. I let Comodo do its thing and turn the Windows one off.

The 3rd link you gave me looks like the one I used. In fact, it is. =O

Plus, I simply have no patience with searching forums. I always make a bit of an initial effort which is quashed by the awkwardness of forum search results… ;D

I must say, I am genuinely impressed by Comodo, but I am starting to lose patience… I’d hate to have to get rid of it. I can’t even find any evidence that Comodo’s causing the problems…

Anyway, I’ll need to sort it out before I consider using one of the little sign smilies ;D

In your earlier post you say:

The weird thing is that these problems still occur when I completely shut Comodo down. Is this normal behaviour. Is it even Comodo at all? I kind of hope so...Or else I have something seriously wrong.

If you shutdown CFP completely, it shouldn’t be interfering with your Internet access, likewise if you set it to allow all.

Did you try Little Mac’s suggestion?

Here’s a “fun” little link for you as well: https://forums.comodo.com/index.php/topic,6167.0.html. In the top post, look for the item named “Network Rules Defined.” This will list the rules created by a “default” or “Automatic” install. You can remove all your existing rules and replace them with those six rules (ID 0 - 5). That will get us back to the baseline.

However, after your recent comment, I realized that I mis-read your first post… I thought you said there that if you changed it to Allow All it would work, not that it still didn’t work.

If changing to Allow All it still won’t work, that typically indicates it is not a Comodo firewall issue. Possibilities (that I can quickly think of) include a botched install of CFP because of an antivirus program actively running during the install, or some other oddball computer glitch that just happened to occur when you needed it not to… You might want to do this (it’ll take a couple reboots, but not much time other than that): Uninstall & reinstall CFP.

When you do both of these, make sure you completely turn off/disable any active/real-time/on-access AV or antispyware (or other security) applications.

Then from the systray icon, Exit the firewall (thus closing down the user interface).
Then go to Start/All Programs/Comodo/Firewall/Uninstall Comodo Firewall; let it run the uninstall routine. Reboot.

After reboot, clean out the registry of any junk entries (not just CFP, but anything in there). I would recommend using something like ccleaner or regseeker (both free utilities) to clean it out. Be sure to use their default options to backup the registry prior to deletion (just to be safe). Following that, it would be good to reboot again (so okay, we’re looking at 3 reboots).

Then disable your AV/etc again. Then reinstall CFP. Use Automatic (do not choose Manual). Then, your 3rd and final reboot in this process.

Sometimes starting over works wonders…


PS: You shouldn’t have to use a server like photobucket to attach a picture; only if you’re trying to include it in teh textbox of your post. If you have it saved on your computer, you can use the “Additional Options” (bold red letters) below your textbox on each post - just click it and you’ll have a place to browse to attach images (and other files).

aha! Well maybe I thought Comodo was interfering with my connection from “beyond the grave”. Botched install may have been the case. I may have installed Comodo along with Kaspersky AOL AV without a restart. Would this have made a significant difference?

This is really quite bizarre. At first I didn’t suspect Comodo of anything, but when three issues (MSN connection problems, upload troubles, and a little download issue) all happened in sync, I pointed towards the firewall as the culprit… ;D

So I uninstalled both programs and voila! Everything seems to be fixed! Must’ve been a pesky one off glitch sparking a reaction between something…Meh!

Anyway, I shall get round to reinstalling Comodo right away.

Thanks for all of your help, guys.



Oh and another thing, not even attaching the file in these forums would work!

Okay, I’m glad that getting back to your baseline has worked.

Keep us posted on your developments. And do be sure to disable AV when reinstalling CFP. Be aware, too, that some users (not all) have had some significant compatibility issues with KAV and CFP, where KAV refuses to communicate with the firewall, rejects the firewall, demands that the FW be uninstalled, etc. I have not (not my knowledge) seen your issue related between the two.

If, after reinstalling CFP, it occurs again, you might want to uninstall both, then reinstall the FW without the AV, and see if it works okay by itself. Then re-add the AV.

I believe the KAV forum says to install it before any FW, but I personally think it should be after the FW (so that it won’t reject the FW installing). BTW, KAV’s problems are not only with CFP, but with many other FWs as well; it seems to be very particular about who it plays with… :wink:


I didn’t like KAV. It’s not coming back =D

Thanks again ;D

Have you reinstalled CFP yet? If so, how’s that working?


Everything’s running perfectly compared to the first time I installed it… Resolved

Time to lock this thread up?


:smiley: Kryters

Consider it done… :wink: (I think Soya beat me to it)

If you need it reopened, just PM a Moderator (please include a link), and we’ll do so.


How were you able to detect my stealthed state without leaving my name? Packet sniffer? Whatever. Leak test passed