Upgraded to 7, now settings not visible, changes do not keep, no tray icon

Just kept up with the updates Comodo offered, now I do not see my connection rules. I manually imported the firewall cfgx file; the notification came up that it was successfully imported but there is nothing listed under Configurations. In fact, none of my settings keep, from unchecking Enable HIPS to changing the buttons on the main window’s task bar. Also, there is no icon in the system tray, animated or otherwise.

Anyone else having problems like this? I’ve looked around but haven’t come across anything like it. But then I only have firewall installed, maybe this problem came up with other types of CIS installations.

I’m running Win7, also Avast antivirus. I tried doing a complete uninstall of both, a registry cleanup, then reinstalled Comodo Firewall only. It didn’t solve the problem.

Hi dutara,
Imported configurations need to be activated to come into use.
Selecting and Implementing a different configuration profile

For your icon issue, check that it is not set to hide.
Change how icons appear in the notification area-Microsoft

Kind regards.

Thanks capt, but one problem is my configurations don’t appear after I import them, even though I get a dialog saying the import was successful. Hence, cannot activate what is not listed.
No icon to select/unhide, no mention of Comodo in the selection of taskbar notification icons.

Still hoping to hear from someone who has had the same problem (and solved it!).

When importing a configuration it is best to give a different name like CIS Proactive Configuration Imported. Otherwise it will overwrite a profile with the same name.

Try running the Avast clean up tool. It can be found in this list: ESET Knowledgebase . If you had other security programs installed in the past please run clean up tools for those programs too. Sometimes a service or driver gets left behind when uninstalling and that may cause unexpected effects.

Then I would reinstall following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron.

Also clean up the registry with Auslogics Free Registry Cleaner and Eusing Free Registry Cleaner. Now try installing again.

I can confirm this problem.

I’ve installed Windows 7 (SP1 integrated) a few days ago in VMware Player and have been installing applications and fine tuning the system since then. Neither the previous 6.3 nor the current 7.0 version of Comodo Firewall install properly, showing the same symptoms as described above.

When installing directly from the MSI (unpacked manually from the installation EXE, a 7-Zip SFX), it becomes suspicious that the otherwise lengthy step of “cloud validating running applications” (or whatever it is called) is missing and installation finishes too soon. This is probably a consequence of the same base problem as the other symptoms.

The firewall starts up (after reboot) very “uneasily”. If I run the main program, cis.exe, manually, it starts up but whatever configuration changes I make are lost: if I open advanced configuration again (without even exiting cis.exe) the settings are the same as before. If I manage to make the tray icon appear (cistray.exe, does not always start), changes made in its context menu seem to be accepted by the engine (services running in the background) - e.g. I get a confirmation message about disabling the firewall - but settings in the tray icon’s context menu do not change.

I can’t start applications most of the time either. I get messages about having no permission to access files - even on FAT drives where file permissions do not exist. Actually, I can’t even uninstall the program (see more below) because the Windows Installer service is also inaccessible.

If I manage to change settings directly in the registry (HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro), I don’t see the changes affecting the engine. It’s as if the engine was blocking (sandboxing?) everything. This seems logical, though, as the list of configurations is empty. (The three initial configurations are imported upon installation as I can see them in the registry.) If I import my own configuration, the import finishes with success but too soon and nothing appears in the list of configurations. I can’t see it imported in the registry either.

If I manually disable the enigne (see below), delete the three initial configurations in the registry, import my own and then enable the engine again, I can see my configuration in the registry but not in the normal menus (cis.exe) and the symptoms are still there.

Parts of the engine (cmdagent.exe, cavwp.exe, cis.exe) cannot be killed from Task Manager and the Comodo Internet Security Helper Service (= cmdagent.exe) cannot be stopped but these should be part of self-defence. If I manage to start any file manager then I can rename cmdagent.exe to cmdagent.ex an CisTray.exe to CisTray.ex (not nice! ESET NOD32 protects its own files!), reboot and the engine is disabled. Then I can run applications and uninstall Comodo Firewall.

I suspected that file/registry permission are the root cause but adding my own user with full control, inherited, to the registry key (see above) does not help. I haven’t played around with files yet. (Note: Windows 7 installs on NTFS only so the system drive does have file permissions.)

My Windows XP, installed almost ten years ago (!), has been fine tuned to death: it has compatibility problems with sloppily written programs. Comodo Firewall 6.3 has been working fine for months on it so Windows 7 itself must have something to do with this.

This is all I’ve come up with yesterday. Now I have work to do so I suspended experiments.

To get a clean start:

Let us know if that helped to get you started again.

CIS allow users to such things. CIS is the nanny of program behaviour not the nanny of user behaviour. An unknown program would not be allowed to do what you did.

While it doesn’t profit any of us there is some relief in knowing I’m not the only victim of this. I too to came to the conclusion that there is a permissions problem somewhere that is preventing my settings from being kept. Yes, I did all the recommended cleanups beforehand, and yes

Then I would reinstall following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron.

So no need to for the mods to tell us about that yet again. Also did my own manual searched of registry and disks. I spent two days on this, then gave up, now using another firewall product.

I was running only the firewall. The troubling thing is I just let Comodo auto-update, never had to deal with it except to block/unblock things, and answer alerts of whether to let something have access. One day I went to block something and noticed there was no Comodo icon in the tray. I didn’t have time that day, so I ignored it, then about a week later I realized it was a bigger problem. Though the background processes show up in process explorer I don’t think they were doing what they should, which means I didn’t have a functional firewall and was unaware of it. False security.
But when something is free you really can’t complain much. After spending all the time I did, as did sta64. ‘free’ is not worth the effort. I wanted a firewall, not a hobby.

Mods, thanks again for:
Then I would reinstall following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron.
I tried it and didn’t solve the problem.

I ran both Auslogics and Eusing Registry Cleaners. They messed up Windows, deleting a few required registry entries, but I fixed them manually. I ran as Revo Uninstaller (advanced uninstall), too. I’ve been using CCleaner for years, I cleaned the registry with it. Still the same. At this point, I give up.

Hi sta64,
Registry cleaners have potential to cause more issues than they fix, as you have found out.
Excessive use will always increase the risks. :wink:

Kind regards.

I agree.
My subject example of it.

I have been using Auslogics and Eusing registery cleaners without glitches over several years. They are in my view safe enough to advice to the wider audiences.

I can’t really comment on the Eusing Registry Cleaner here, as I’ve only been sparsely using it in the past, but Auslogics Registry Cleaner has never let me down for many, many years now, and it’s regularly being updated.

I recommended it in 2009, and I continue to recommend it. Lovely software. :slight_smile:


Kind regards, REBOL.

I’ve retried the installation with Comodo Firewall a few days ago. On my physical Windows XP, it installed fine, the default configurations are shown, I could import settings from 6.x (that I’ve been using before) and is working ever since. On my virtual Windows 7 32-bit, it also works fine, I could import settings that I’ve exported from the same version running on the physical Windows XP. However, on virtual Windows 7 64-bit, it still shows the same symptoms as described above: default configurations are not visible, I’m unable to import my own configuration, weird permission problems block the launching of applications, while the registry entries for the configurations do exist and have permissions that allow the system to access them. I have the strong feeling that one of Comodo Firewall’s own components (the protection) is blocking access from another (the configuration client).

If you did a clean install following Most Effective Way to Reinstall CIS to Avoid/Fix Problems by Chiron and you have no other security programs running in the background we may be looking at a bug.