upgrade to v3 does not go well

I have been using ver 2.4 on my Win2k machine with good results for a while. I just upgraded to XP Pro so decided to upgrade to ver 3 of Comodo firewall. This is when all the issues started.

1st my machine is a Pentium 4 3.0 ghz with 1gig of memory and two hard drives set up as a Raid.

When I tried to install 3.0 it gave an error 2 and said it would roll back. This is after I disabled NOD32 and Spyware Doctor. I then tried disabling everything I could in Msconfig and still no go.
I then booted into safe mode with networking and it installed just fine. Or so I thought.

Unfortunately, when I rebooted it showed that I had no internet and Comodo said at the bottom of the screen that the firewall was not working. I tried the diagnostic tool, but it said all was fine.

I looked at similar posts here, but most of the so called fixes have done nothing…assuming I did them correctly.

There was one post that suggested that Comodo is not compatible with dynamic disks…isn’t raid considered a dynamic disk? I find that hard to believe since your earlier version worked just fine with my Raid setup.

Any ideas…and if so, please spell them out in greater detail. Although I am fairly computer savvy…I am the zenith of my knowledge when it comes to configuring your version 3. In other words, I don’t really understand many of the settings and features in ver 3 and what is best or needed.
Thanks in advance.

Did you COMPLETELY remove 2.4 before installing 3.0? You did say anything about that.

Well no…but when the install of 3 said that it would uninstall 2.4, I just let it do its thing…however, the uninstall did not go well and reported that a file could not be deleted. I may be wrong but I thought it said it was a driver. So I reinstalled 2.4 and then uninstalled it through Add/Remove. I even found a post that said where else on the hard drive to look to delete files and where to look in the registry to delete more. Of course none of the legacy entries could be deleted in the registry.
Even after all that, 3 will not function properly when I try to install it.
I currently have 2.4 installed and working.