Updating microsoft.com/kb/2919355 causes diagnostics error [M963]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    It happened on two computers every when the update to Windows 8.1 was performed
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Install CIS
    2:Update Windows 8.1 to the following update Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update: April 2014 - Microsoft Support
    3:Note that there is now a diagnostic error
  • If not obvious, what U expected to happen:
    The update should not cause any problems with CIS.
  • If a software compatibility problem have U tried the conflict FAQ?:
    NA
  • Any software except CIS/OS involved? If so - name, & exact version:
    NA
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    This was a fresh install of Comodo v.7.0.315459.4115 before the upgrade to v.7.0.315459.4132.

Doing a fresh install after the Windows update was able to get rid of this diagnostics error. A diagnostics report from a computer experiencing this issue is attached to this post.
[/ol]

B. YOUR SETUP
[ol]- Exact CIS version & configuration:
CIS 7.0.315459.4132

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Default
  • Have U made any other changes to the default config? (egs here.):
    No
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    Yes
    [li]if so, have U tried a a clean reinstall - if not please do?:
    Yes
    [/li]- Have U imported a config from a previous version of CIS:
    Yes
    [li]if so, have U tried a standard config - if not please do:
    No
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 8.1 Pro 6.2.9200 SP 0.0 64 bit
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=None b=None
    [/ol]

[attachment deleted by admin]

I’m sorry, but I am not really understanding the problem you are experiencing. Can you please edit your first post so that it is in the format provided here? Just copy and paste the code. Then replace the question marks with your responses.

Thanks.

Hello,
1: CIS version:
Comodo CIS v.7.0.315459.4132
2: OS version:
Windows 8.1 Pro (x64)
3: What you did:
Following a major update to Windows 8.1 see below Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update: April 2014 - Microsoft Support
4: What you actually saw:
After rebooting the PC = > Comodo CIS v.7.0.315459.4132 is in default on the diagnosis ( registry)
5: Restaure CIS v.7:
Uninstall Comodo v.7.0.315459.4132 is performed by the panel Panel => Programs and functionality + reboot, then to save time I used CCleaner to clean files and unnecessary registry keys + reboot in Finally I reinstalled Comodo v.7.0.315459.4115 then updated database + quick scan to finish Comodo went to upgrade v.7.0.315459.4132

  • New score = > 2 PC is Ok to level diagnostics.

I bet that’s your problem right there. Registry cleaning is neither necessary nor wise.

Hello,
My problem affecting other PC ? ???
Check the order of operations above
The diagnosis of Comodo being negative after updating Microsoft (and not before).
You possess Windows 8.1 Pro (x64) to discuss?
Have you done the last update above ?
Then you have control the diagnostics Comodo?

I’m sorry, but I will need the first post edited so it is in the format provided here. The shorter one does not have enough information for the devs to diagnose an issue such as this.

Also, are you saying that after the update the diagnostics no longer functioned for either computer? Sorry, I’m having trouble understanding.

Thanks.

Hello Chiron,
Sorry for the misunderstanding
Two computer failure was the same after the update Microsoft Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update: April 2014 - Microsoft Support.
Windows 8.1 Pro x64 French
Diagnosis shows an error (registry) after update
Corrected after reinstalling CIS (Comodo CIS v.7.0.315459.4132)

Okay, so let me see if I understand.

1: You first had CIS 7.0.315459.4132 installed on the computer, and running the diagnostics finds no problems.
2: You then updated Microsoft Windows.
3: After the update was complete running the CIS diagnostics finds an error in the registry.
4: Reinstalling CIS was able to solve this as any subsequent running of the diagnostics no longer finds any errors after reinstalling.

Is the above correct?

Exactly !
Same error on two different PCs with Windows 8.1 Pro x64
This update from Microsoft is significant in size.
The interface is radically changed (right click tile)
cordially
ZorKas

Did you notice any issues with the computer, or was the only problem encountered the diagnostics report finding an error?

No malfunction
Just this error Comodo

Okay, now I think I fully understand. Please edit your first post so that it is in the format. I can help you finish it, but the format is needed.

Thanks.

Post edited first

Okay, I think there may be a misunderstanding. I just pasted in the correct format. Please edit that post and replace the question marks with your responses. Please answer all which you can. We can then work together to fill in the remaining.

Thanks.

Here in France it is the night (I sleep)
Tomorrow morning I replied to the form
thank you Chiron

No problem. If you have questions while filling it out feel free to ask.

Thanks.

Hello Chiron,
Spot #1
Post edited first
Cordially
Zorkas

Thank you very much for putting the format in the first post. I made some changes to it. Please look it over and let me know if it seems correct.

Also, please attach the diagnostics report to your first post. If possible attach a diagnostics report from a computer which shows the error. However, if that’s not possible then attach it from one which used to, but a reinstall solved the problem.

Thanks.

“Please look it over and let me know if it seems correct.” => Yes
“but a reinstall solved the problem” => Yes
Thanks
Note: Windows Update will offer and install multiple packages in KB2919355

Thanks. However, please attach a diagnostics report in the first post. If you have questions about how to do that please feel free to ask.