Updating List With Empty Rules Causes Hang-Up [I21]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    It usually appears after emergence alerts of Firewall or Defense+ at long inaction of the user.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1: To open rules for applications of Firewall or Defense+ .
    2: If there are empty rules, to open the menu the right button of a mouse and to press “Update”
    3: Process hangs up (doesn’t stop) until Windows reset
  • If not obvious, what U expected to happen:
    Empty rules shouldn’t be and process of updating the list of rules shouldn’t hang up.
  • If a software compatibility problem have U tried the conflict FAQ?:
    NA
  • Any software except CIS/OS involved? If so - name, & exact version:
    NA
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    Windows restart helps only.
    [/ol]

B. YOUR SETUP
[ol]- Exact CIS version & configuration:
CIS 7.0.317799.4142. Proactive security configuration/

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    HIPS=safe, Sandbox=Partially limited, Firewall=User, AV=cumulative, cloud is on.
  • Have U made any other changes to the default config? (egs here.):
    No
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    No
    [li]if so, have U tried a a clean reinstall - if not please do?:
    NA
    [/li]- Have U imported a config from a previous version of CIS:
    No
    [li]if so, have U tried a standard config - if not please do:
    NA
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7, SP1, 64bit, UAC=off, admin, VM not used
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=None b=None
    [/ol]

[attachment deleted by admin]

Hi,

Does CIS ,eventually, crash?

You could provide more information, if you want, using these tools :

No. CIS works. But if to enter expanded settings, we will see the picture as on a screenshot. As a result, no settings are available before Windows reset.

[attachment deleted by admin]

OK. I’ve been experiencing this issue.
Seems like it usually happens when there are too many files in your unrecognized list causing unexpected behavior (as in ‘lag’).

Could you try this work-around?
https://forums.comodo.com/defense-sandbox-faq-cis/unrecognised-or-submitted-files-cis-states-the-wrong-number-t78834.0.html;msg564399#msg564399

Thank you.

For example, now CIS works normally. Updating of list of rules work correctly. But if in the list there are empty records, updating process (cleanings of rules for nonexistent appendices) don’t stop (hang).

The folder [u]c:\Program Files\COMODO\COMODO Internet Security\database[/u] is empty. There are no files.

Thank you for reporting this. Please try to create a Full Dump of the process which is hanging by using Killswitch. Let me know how that works.

Thank you.

I don’t know what is process. Simply updating of the list of rules doesn’t stop, if there are empty rules. It is necessary to find out why they appear.
Now everything works normally. I don’t know when this situation will repeat.

When you believe it may occur again, please have KillSwitch open. Then try to initiate the hang. Then, right-click on the process you believe is hung, select Create Dump, and select Full Dump. If that process does not let you make a full dump of it, as some do not, then please create a Full Dump of a process which may be even tertiary related and lets you make the Full Dump.

Let me know how it goes or if you have any questions.

Thanks.

ок

Have you been able to create the dump for this yet?

PM reminder sent.

I will now move this to the Incomplete Issue Reports board.

Topics in this board are not looked at by the devs. The reason is that putting bug reports in the required format, with the required files, ensures that the devs have enough information to understand and identify the bug.

To get your report forwarded to the devs please create and attach the dump file when you are ready. Once I have that I should be able to forward this directly to the devs.

If you have any questions please do not hesitate to ask.

Thank you.

Can you please check and see if this is fixed with the newest version (8.0.0.4337)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Also, note that all bug reports in the Non-Format section of the forum, which is where this report currently is, are mainly not looked at by the devs. Thus, if the bug you were experiencing is still not fixed please edit your first post so that it is in the correct format (found here, with all required attachments), so I can forward this to the devs and get this problem fixed.

Thank you.

I have the same problem after re-Installation date 25 jan 2015.
win7 x64.