updating fire wall

Why can I only update with IE and not with firefox?

I can only update comodo firewall with IE. Why
I would like to connect with firefox
Is it possible if Yes how