Updater showing odd dialogbox

I keep on getting a popup for the updater which only contains two labels saying “static”. See screenshot. Is this a genuine Comodo dialogbox? Or should I be concerned that it’s a virus?

Note that I’ve since manually updated by downloading from the Comodo website, but I’m still getting this dialog popping up.

[attachment deleted by admin]

Hi dracan,

Static is uses as a place holder for other texts that should have appeared in there.
Seems like something is going wrong with painting your updater screen.

Have you been using an other language on CIS perhaps ?

Does it appear after a reboot also ?

If you are on version 3.11.x. then there is an update available to 3.12.x.560

I’ve been having similar issues with the “COMODO Internet Security - Updater”, as well as odd startup behavior from the COMODO Internet Security’s ‘control panel’. One or the other will randomly pop-up during start-up (if Updater, then it appeared as dracan’s screen shot illustrates minus the “Automatic Updater” dialog). When the control panel does this, I have to manually close the dialog. With the Updater it typically closes itself and the start-up process continues as normal. However, some times I have to manually close the Updater dialog.

A new twist, which may be unrelated to the problem described above, is that literally right now the Updater dialog refuses to close. It popped-up on its own and while I can Pause/Continue, minimize, or click Help, the the dialog box will not close. It claims it is “Checking updates…”, but cfpupdate.exe is not generating any network traffic and is sitting idle as far as the Windows Task Manager is concerned.

FYI, I’m running CIS ver. 3.12.111745.560 (2969) on Windows XP SP3. I’m also running LiteStep ver. 0.24.8 (Theme: Simple by MrJK), which I initially thought was the cause of of the mysterious pop-up dialogs. After all, running an alternative shell you expect certain glitches. However, yesterday I was using the default Explorer shell and had the same behavior of the Updater popping up and closing on its own. This seems to rule out LiteStep as a possible cause, and hence my post here today. BTW, the odd start-up behavior wasn’t isolated to ver. 3.12 of CIS. Earlier releases were affected as well, unfortunately, I don’t recall exactly when it manifested itself. I’m pretty sure it started around 3.10, but I could be wrong.

I still get this. Daily, I have to click on the “Start” button on the larger dialogbox in my screenshot. Then it commences to check for the update. I’ve tried uninstalling, then reinstalling, but that doesn’t help.

It appears that this glitch is also present with CIS 4.0(.138377.779). The interesting thing is that I think I’ve figured out why the Updater dialog refuses to close. It refuses to close only when there is actually an update available. Thing is, in order to install the available update, I have to first log off/login in and then either run the Updater manually, or download the installer and run it. BTW, this behavior only affect one of the three systems I have running Comodo.