Updater keeps asking to update

I have allowed commodo to update on both a Vista32 and an XP Pro PC and it keeps on telling me updates are available. There is a bug in the latest updater!

What version of Comodo are you using?

It reports as 3.8.65951.477

Download and do a clean install.
The latest is 3.9.81003.508.

Thanks
Trevor

A question… why is the webpage Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year still mentioning Version 3.9.76924.507 : 13th May, 2009 as the latest one, when there’s a newer one already?

Another question… I updated from version 3.8.65951.477 to 3.9.810003.508, but I’ve just read that an uninstall of the old one (any old one?) and then an install of the newest one is advised.
Is it adviseable to still do an uninstall and then a re-install? (Everything seems to be working fine right now).

Thanks.

Update:
There’s already ANOTHER update of CIS! It’s version 3.9.95478.509 .
Still no update of the release notes though…

Working with a XP Home Ed. PC until last December, I never met such a problem.
With my new (Vista-32) PC, I did have such messages, until I recently found out that exiting Comodo, and then restarting Comodo as an Administrator did the trick: the updater worked, at last.

By the way, has this “trick” been documented somewhere on the Comodo forums? I wouldn’t be surprised if there are more Comodo users who encountered this “update problem”!

Greetz,
Theo

For vista this is probably leftovers in the VirtualStore, please check the FAQ here:
https://forums.comodo.com/install_setup_configuration_faq/cis_keeps_telling_me_that_there_are_updates_available-t36364.0.html

Saw that FAQ earlier, it didn’t help me though; not sure what this “VirtualStore” is…
Could you help me out on this? No folder VirtualStore on my PC…

On vista it will be on your c:\users[b][/b]\appdata\local\virtualstore and it could also be on c:\users[b][/b]\local\appdata\virtualstore

It could be that you have to change the explorers settings to show hidden files and folders for you can see them, you can also use a command-box to find it.

Open a command box and type

cd \

you should now be on c:> then type

dir virtualstore /s

And press the ENTER button after that.
Output should look like this:


 Volume in drive C is System
 Volume Serial Number is xxxxx

 Directory of C:\Users\[b]<UserID>[/b]\AppData\Local

06-04-2009  13:48    <DIR>          VirtualStore
               0 File(s)              0 bytes

 Directory of C:\Users\Administrator\AppData\Local

03-04-2009  22:04    <DIR>          VirtualStore
               0 File(s)              0 bytes

     Total Files Listed:
               0 File(s)              0 bytes
               2 Dir(s)               0 bytes free

Where is your logon name for the system.

I’ve had that same problem for over a year now. It’s amazing to me that Comodo hasn’t handled it. I just ignore updates and check the current version every month or so to see if there really IS an update available. Otherwise you keep installing the same version over the old.

Dave

Hello Dave,

The issue is solved, but you have to manually clean up the stuff the old versions left that cause this.
An other thing could be modifying the “Trusted vendor” list if you do that the updater will also alert you that there are updates because the file hashes no longer match.

Hi Ronny,

Thanks for your reply.

That’s good news, sort of. I have a new computer and a new install of Comodo. I’m getting updates every two days or so. Possibly there have been a lot of updates recently. Can’t discount that possibility.

Dave

i have the same problem.
i had installed 3.8.65951.477 and it wants to update… so i updated but it still keeps asking to update no matter how often i updated. :frowning:

today i unistalled commodo and downloaded the latest version.
after installation of the latest version from the website: CIS_Setup_3.9.76924.507_XP_Vista_x64.exe
it wanted to update again… so i let it update.

now it STILL wants to update and my current version is 3.9.81003.508.

im always have administrator rights on my PC`s.
the virtualstore directory on my harddisk is empty.

this is driving me crazy…

Sorry there has been three 3.9 updates recently.

First was main update .507

Second for virus update path should have changed with .507 but did not .508
(Some members have had problems updating there virus update)

Third update for freezing on some computers which has cause problems for some time.
Thank you to the member who helped cure this .509

Thank you
Dennis

ah ok thx… i thought the same problem i had with the 3.8 version keeps on bugging me.

would be nice if the realease notes on the update page would be up to date.
then this all would be a lot clearer to the users. :slight_smile:

To the powers that be…

The release notes page still shows .507 as the latest release…

This must be confusing for some who don’t look on the forums.

However both my machines updated OK via the automatic updates from .477 to .509 (via the 3 updates) with no problems; no uninstall/re-install appeared to be necessary. :slight_smile:
I can only assume that the complete uninstall/reinstall method was mentioned for those who had problems.

Would have been nice if we had been warned of the large size of the update file though. :frowning:

Keep up the good work Comodo. :slight_smile:

Mike.

I updated to .509 the Firewall part only a few weeks ago without any problems whatsoever. However just the last few days I have been again getting the update available notice but when I start the updater, either through the task bar notice or through the main GUI, it tells me that there are updates available. I then start it, it goes way and checks and always comes back telling me that there are no updates available. If I then do a manual check or reboot I again get told there are updates but again when I actually allow the updater to check I again get told there are no updates. I have also tried the delete all files in Virtual store and copy files from Repair but it makes no difference. As I have quite a few Vista machines I have now disabled the auto update check and will for now do a weekly manual check. BTW, none of my XP/SP3 machines have this problem only my Vista SP1 and SP2 machines. This is getting to be such a common repeat problem that I think it is time to look for another more reliable program and less time wasting firewall. And yes I know it is a free program but even a free program needs to be reliable to be trustworthy and not unnecessarily waste the users time.

Hello Jcym,

This could be caused by a few things, what basically happens is that the updater check a bunch of files against a hash list, once one of these files has a local different hash the updater will kick in and start complaining there are updates.

Known causes are

  • Modification of the Trusted vendor list
  • Vista’s Virtualstore
  • Real updates available

Can you download Hashmyfiles here:

Extract that and run a hash over the c:\program files\comodo\comodo internet security

Save the results via “View, HTML Report all items” zip it and post it here, then i can check the hashes and see what causes this.