Updater Issue [resolved]


Whenever I try the updater, I get the following error dialog when I click “start”:

Comodo Firewall Automatic Updater

Your system seems to be not connected to Internet. Please check your Internet Connection.

I use Comodo Firewall version & IE7 RC

Everything else seems to be workng properly.

I’m having the same problem, using Comodo and IE 6 version 6.0.2800.1106.xpsp2.050301-1526IS. I am connected to the internet as I’m using the same PC to type this! IE connects to the internet just fine too so if Comodo is using the same settings IE uses then it SHOULD be fine but it’s not and I can’t see why. Can anyone help?



Are you able to update if you adjust the security level from “Custom” to “Allow All”? If so, this may indicate a configuration issue. If not, does anything appear within the logs?


It doesn’t make a difference what security level I am in. It does not even seem to try to connect. For eample, in the activity screen there are no new entries at all.

I also tried specifically giving this application “cpfupdat.exe” permission(TCP/UDP out) to access in the “Application control rules” within comodo.

There is no significant delay between the time i click start and the error dialog which means that it is simply not a timeout.

ps. nothing in the logs either.

Have you tried re-installing CF?


If you can look at my monologue here:
you can maybe understand why I won’t be reinstalling in a hurry :slight_smile:

Edit: I’m attaching a screenshot of the error.

[attachment deleted by admin]

It makes no difference for me either, and nothing in the log, apart from a UDP port scan. I’ll try re-downloading & re-installing Comodo.

Thanks for your help.

Okay people, good news :slight_smile:

I did not change any setting (unless I was sleepwalking), but no more error for me, woohoo!

I have the same problem. :-\

I am having the same problem. I have tried downloading the file again and reinstalling. But it is still telling me that it can’t connect to the internet, even though I am able to browse the internet.

I have also tried installing a previous version and get the same problem. How do you do a full clean install? Even when I unistall and reinstall it doesn’t ask me to enter my registration number so there is clearly stuff being left behind in the registry.

I am using Comodo Firewall version

I think I have figured out was causing the updater issue. It seems to have been a conflict with an app called regcleaner. As soon as I uninstalled regcleaner, the update function was able to connect to the internet. Don’t know if this will help anyone else.

Well, I’m afraid I don’t have Regcleaner installed so it can’t be that for me. I have Avast running but stopping that makes no difference. Anyone still around to help me out? I uninstalled and re-installed, still no good.


I always had this problem , with ie6 (ita) , ie6 (ita) and no I don’t have regcleaner.

Any idea ?