updater failed - cfp.exe : invalid signature

Haven’t been able to update CIS since I installed version 5. virus definition updates fine but when i go to more-check for updates-start it starts installing, gets to 40% and then says “cfp.exe : Invalid Signature.” I have tried replacing the cfp.exe with the one from the repaired folder, and made sure it wasn’t blocked or anything in comodo but nothing works.

Sorry if this has already been addressed but I couldn’t find it using search.


You may consider uninstalling CIS with Revo Uninstaller and install the v5.3.

Thanks for the reply. I tried your suggestion and when the computer restarted after using comodo’s uninstaller (through revo), it didn’t show up under Revo when I pulled it up again. had to manually delete the folders/files as well as searched through the registry for “comodo”.

When I tried running the installer you directed me to it says it can’t remove the old program. I’m stumped, normally cleaning the registry allows programs to install in these instances.

Any more ideas?

Yes; run the CIS clean-up tool.