Update saying all the time that it does not work (failed to update?) I know you might not have a new version but still is this normal?

Okay let me put it like that. Anyone else has this issue?

Hi Seany007,
No, I have tried to reproduce this and can not.
Have you any third party extensions that could be blocking or interfering with the updater?

I’ve got the same error here with no extensions added?

[attachment deleted by admin]

Try right clicking IceDragon and Run as administrator, then check for updates.

Hi captainsticks,

Yup, when run as administrator it checks for updates O.K :-TU

As running an admin account ( :-X ) I would have taken it that it would check for updates without the elevated level ??? - sometimes the simple answers are over looked 88) until we come on such a friendly and helpful COMODO Forum, where members are always willing to help (:CLP) :BNC



Hi Dolphin66,
Glad that worked for you.
Administrator rights/permissions appear to vary a great deal depending on system set-ups.
I am not sure why this is required on some systems to update.

Please note: I recommend after checking for updates, to close CID and re-open as normal for general use/browsing etc.
Kind regards.

Worked for me as well. Go figure. Thanks ;D :-TU

You are welcome Seany007, glad that worked.