Update refuses to restart. [Merged]

Hi all,
I’ve tried several times to install the recent IceDragon update (I currently have 48.0.0.2) however after it’s downloaded and I click ‘restart now’ nothing happens. I’ve tried several times to no avail, and even restarted IceDragon manually but it doesn’t work. I’ve never had any problems with updates before.
I’ve attached a copy of the troubleshooting text and I have avast antivirus.
Any help would be appreciated.
Thanks in advance.

Application Basics

Name: IceDragon
Version: 48.0.0.2
Build ID: 20160829133844
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
OS: Windows_NT 10.0 x86
Multiprocess Windows: 0/1 (Disabled)
Safe Mode: false

Extensions

Name: Adblock Plus
Version: 2.7.3
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: AddThis
Version: 3.6.5.2
Enabled: true
ID: {3e0e7d2a-070f-4a47-b019-91fe5385ba79}

Name: COMODO SecureBox
Version: 0.0.1
Enabled: true
ID: [at]csb

Name: DragAndDrop
Version: 2.1
Enabled: true
ID: DnD[at]comodo.com

Name: Firefox Hello
Version: 1.4.3
Enabled: true
ID: loop[at]mozilla.org

Name: Flash Video Downloader - YouTube HD Download [4K]
Version: 13.2.4
Enabled: true
ID: artur.dubovoy[at]gmail.com

Name: HTTPS Everywhere
Version: 5.2.5
Enabled: true
ID: https-everywhere-eff[at]eff.org

Name: Multi-process staged rollout
Version: 1.0
Enabled: true
ID: e10srollout[at]mozilla.org

Name: Pocket
Version: 1.0.4
Enabled: true
ID: firefox[at]getpocket.com

Name: Tab Groups
Version: 2.0.1
Enabled: true
ID: tabgroups[at]quicksaver

Name: Thumbnail Zoom Plus
Version: 4.0
Enabled: true
ID: thumbnailZoom[at]dadler.github.com

Name: Translate This!
Version: 3.5.0
Enabled: true
ID: jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc[at]jetpack

Name: Firefox Hotfix
Version: 20160826.01
Enabled: false
ID: firefox-hotfix[at]mozilla.org

Graphics

Mod edit: Added merged to the topic title, Captainsticks.

Hi

Just this second updated IceDragon (after being prompted) and now when I load IceDragon, this error message appears each time (see below).

:slight_smile:

UPDATE: Logging on as administrator solved this issue for me by completing the IceDragon installation.

I have this also and it tells me i have a missing file on my pc i had to use system restore to fix and go back to 48.0.0.2
there is a bug in this update needs a fix fast or browsers everywhere will crash

Yes i have this bug if a bug i get a error box with it telling me i have a missing file or program on my pc and need to reinstall the file to work
all updates before work as normal till this one today 20th oct and had to use restore to fix

I just installed the update and it broke my browser as well. It said I was missing a .dll file and refused to start up, but since I had to do a system restore to a point I’d saved last night in order to get back online, I no longer know what the name of the file was.

Uninstalling CID 49 and installing 48.0.0.2 didn’t work, it was still missing the .dll file.

Come on guys there is a error in the latest update and needs your attention or risk thousands of people
with a error box on there screen and a browser that will not load and us all trying to find this missing file to fix so the update work but its not are computer its the update
and we don’t have a missing file or program to reinstall, and only a system restore will fix but not everyone can use this option if there restores are old or corrupt
this is why i keep my setting set to check for updates but let me choose to install them. :P0l

Yeah, the latest update is broken. After I installed it I got this error.

After installing the latest update to Ice Dragon this morning it refuses to run. When I attempted to run it, I would get a error message. I also got a few other error messages during the installation of Ice Dragon 49.0.0. I think the installation file is broken and needs to be repaired.

Thanks everyone.
I’m glad it’s not just me then. ;D

Merged topics.


Hi Guys, Sorry to hear about this issue, fortunately mine has updated without any problems.

It might be worth running the current installer and selecting the repair option

Direct download version CID 49, size 57 MB.
https://download.comodo.com/icedragon/update/icedragonsetup.exe

Kind regards.

I’ve tried that but I still get the same problem. I’ve even tried doing a fresh install and it still doesn’t work. I’m running Windows XP Pro SP3 32Bit Edition on my laptop and I have no problem running Firefox 49.0.1 on it.

Further to my post yesterday, having logged on with the administrator account seemed to fix the problem by completing the installation. Logged back on with my limited account and IceDragon now working.

:slight_smile:

Repair option did not work.

I love this browser but updates are really slow and now they’re rolling out broken, I may have to find another browser if this isn’t fixed soon. That would be a shame but come on.

Hi thanks for this. I ran the installer from the link. It didn’t give me an option to repair however, although it did successfully update loosing all my recent activity and add-ons. 88)
I have now reinstalled them all and it seems to be running ok. :-TU

IceDragon proceeded to update on me without asking for permission, and now I can’t run it.

I get a message that api-ms-win-crt-runtime-I1-1-0.dll is missing

I’ve tried running repair, and I’ve tried a total uninstall and fresh install - neither fixes the problem

Not happy :frowning:

Seems we have to wait for this bug to be fixed in 49.0.0.1…

The same DLL is also in Firefox’s install folder so a full reinstall from an offline install package should fix it. Did you guys do this with the offline installer(s) of both versions or just use the 283kB icedragonsetup.exe file? I wonder whether copying it from Firefox’s folder could be a workaround.

Anyway, that’s why I never ever update apps through the (convenient but arguably stupid) in-app updater. Firefox has been known to have bugs and exploits in its maintenance service (auto-updater) so better off without it IMO…

you’ve lost me there! mine did an automatic update (no idea why - given the option I set everything to notify me an update is available) and that failed. So I went to the website and grabbed the install file from there. Tried that as repair - no joy. Uninstalled and tried it as new install - still no joy.

Anyway, that's why I [b]never ever[/b] update apps through the (convenient but arguably stupid) in-app updater. Firefox has been known to have bugs and exploits in its maintenance service (auto-updater) so better off without it IMO.....
lost me again. No idea what an in-app updater is, unless that's the thing I disable if I'm asked whether I want software to update automatically / never / notify me when available. If asked that I *always* opt for notify me.

Same error here: api-ms-win-crt-runtime-I1-1-0.dll is missing

I re-installed 48.0.0.2 and that works.

Also as part of 49 Comodo went and installed their anti-virus without any notification. Poor showing all around.

The automatic update doesn’t use the full package/offline installer. When you went to the website, did you get the 283kB file or the full 50+MB file? The 50+MB file is the offline installer.

Yes, it is that.

Hopefully someone can come along and try the .DLL from the Firefox folder if they have FF(Firefox) installed and post back here with the results. Of course the hashes would have to match. If anyone’s interested;
File: api-ms-win-crt-runtime-l1-1-0.dll
MD5: 2f10f2255271b09d58af75f58476899c
SHA-1: ca37f8e4c99fb178e718e99eed286d1ef32b00fc