Update problem


I’m using Win7 SP1 x64 and COMODO Firewall 5.4. When I tried to update (through the program), I get to this windows and it gets stuck;


I even tried leaving it over night, but it is still stuck there.

I’m also using NOD32 AV. I tried disabling it, but it didn’t help.

Hey Revz, there has been a similar problem, something about cfpupdat.exe being corrupted or the wrong version. Its is discussed here https://forums.comodo.com/news-announcements-feedback-cis/comodo-internet-security-541898221355-released-t72243.0.html;msg517539#msg517539 Maybe it will help, im not sure.

Could you please go to Comodo Internet Security folder in Program Files and tell us which version of cfpupdat.exe is being reported. Right click/Properties/Details->Specifically the file and product version.
Something you could try is copy and replace the one in the folder with the one found in the Repair folder found in the CIS main folder.
Might be worth a shot.


p.s. An uninstall/re-install is allways an option


The version number of cfpupdat is 5.4.189068.1354 (both the main file and in Repair folder). Copying it from the Repair dir didn’t help.

The version number of the firewall is 5.4.189822.1355.

I will try a fresh re-install if no other solution is available.

If you are going to do a clean installation then don’t forget to export your active configuration and import it back in v 5.5. That will safe you from manually setting up CIS.