Update problem via ICS

I am having the following problem:

I have 1 Laptop (Win XP Home) connected to the Internet via mobile modem and 1 PC (Win XP Pro SP3) connected to the laptop via LAN. I want to update my CIS 3.11 virus DB on the PC.

  1. First I tried the WinXP built-in Internet Connection Sharing (ICS). I do get a connection on my PC, virus DB updater starts downloading but stops after some time (some times a few 100 KB, some times a few MB). Then the progress bar freezes at 30%.

  2. Next I installed a small proxy server (AnalogX) on the laptop (my internet gateway). Now I can download ~25MB of virus DB update, but then again it stops and freezes at 30%. I think the update should be ~100MB, so I don’t think the download was finished already.

Does anyone have an idea, what’s going on? Anyone having experience with this network stuff?

Hi Mike,

I had a similar problem, but my internet connection was working, but it wouldn’t go past 5%.

See my post:


and the solution that worked for me:



When updating the AV after installation it will stay at 30% for quite a while. When also on a slow connection the whole update process may take several hours. My advice for now is patience.

I know that the progress bar stays at 30% for the whole download process (another strange thing; why can’t the updater first inquire the total update size and then display the real download progress?). But the actual download stops (I can see it in the “active connections” window). Is it waiting for something or do the comodo download servers get stuck sometimes? On my ICS host the download never stops until it is finished, this only happens on the ICS client.

BTW: I found an issue about the built-in WinXP ICS sharing a PPPoE internet connection (which my mobile modem is using):


I know, this is getting off topic now, but maybe someone else was/is facing the same problem.
Anyway, it seems the problem is, that the PPPoE can handle only smaller data packets than pure TCP/IP. Since my client connects to my host via a normal LAN, it doesn’t know the host connects to the internet over PPPoE and thus the packets cannot be passed thru. Maybe that is the problem, I’ll look into this.

What version of CIS are you using? When using 3.9 or older please update to the latest.

When you are using 3.10 or later can you disable "Block fragmented IP datagrams under Firewall → Advanced Attack detection settings → Miscellaneous and see what happens?

When that does not help can you show us the firewall logs of the desktop computer? They can be found under Firewall → Common Tasks → View Firewall alerts.

Just for the records: apparently the whole update problem was caused by malfunction of my mobile modem (Huawei 156G). It had nothing to do with ICS, PPPoE or whatsoever. I recorded several hundreds of MBs of traffic and concluded that the problem is not in the TCP packets or on the server. So I sent the modem for repair. The guys replaced the drivers and now everything works normal. The only indication that something was wrong with the modem was in the connection status window of the dial-up the errors crawling up the moment the download stalled.