Update issue

I have just updated Comodo Firewall and it looks like its working yet when I ran the update again just to be sure it said it wasnt up to date yet the version number is the latest one, I then cancelled the update (before even clicking start) and ran the diagnostics module only to find it said there were errors ot could not fix please can someone help me

I personally recommend a clean install over running an update. See if that resolves your problem.

I have tried a system restore because it messed up and now appears to work fine again although the old version has returned its version number still shows as the latest one yet its clearly not. How can I do a clean install of the new version?

ie is there a special way of doing it?

I would like to point out that the updater should work like it does in other programs as the current one is constantly faultering and you shouldn’t have to keep doing clean installs everytime a new updated version comes out as it makes it a long and frustrating process

This is the link to the latest CIS.

To do a clean install, start by uninstalling CIS. If necessary, clean your registries. Disable any active AV scanner you have running. Reboot and install CIS. reboot, and re-activate your AV scanners.