Update issue

Hi guys,

I am trying to update my Firewall, Defense +, but I seem to be getting the following error message:
“Error 112: Unable to copy file: cfpconfg.exe. Please try again.”

Any ideas on what might be causing it?

I also have NOD32 3.0, ThreatFire 3, and SUPERAntiSpyware 4 running on my PC. So far they haven’t had conflicts with Comodo Firewall Pro.

What version are you using now? You can always uninstall and reinstall the latest version. BTW you dont need Threatfire when you have Comodo with D+ active.


actually, I found the answer to my problem in another thread on this forum. It looks like Comodo Firewall Pro has certain update problems under Windows Vista. The solution, which just worked for me, is the following: shut down the Firewall, right-click its icon and choose “Run as Administrator,” disable completely the Defense + and the Firewall Protection (set both to “Disabled”), and then run manually the update–and it works perfectly!

If I do a clean re-install, I will lose all my settings, so the above-mentioned solution is actually better for me.

You will not lose all your settings cause that why there is a import/export feature built in.

I have the same problem as Wyrd. I too am running VU-SP1 and ThreatFire (Defense+ disabled) except mine was a little different - cpf.exe and cpfupdat.exe disappeared.

I allowed the update, rebooted and walked away. I didn’t notice for several hours that Comodo wasn’t running and my system was not protected. The cpf.exe file just disappeared and I had to use the one from the repair folder. When it was started, it again said that it needed to update even though supposedly it already did. (It closed out before I was able to use the update)

I was able to reproduce the problem by updating manually. This time it also came back with this error:

Error 112: Unable to copy file: cfpupdat.exe. Please try again.

and cpfupdat.exe disappeared. (Copied again from repair folder) Tried a 3rd time and it finally updated correctly. I have windows file protection turned off as well as UAC so there’s no need to run as admin but the problem still exists. Is there a way to protect all of Comodo’s files so this doesn’t happen again?

BTW Vettetech… you do lose all your settings in Vista if you re-install. The import & export options don’t work.

Im on XP so sorry but its no big deal. I have 250 programs to relearn. I am sure no one has that many.

Import and export DO work, but there is an extra step you may not be aware of.

After you have imported a configuration, you have to select it to make it active. Only after it is selected are the rules and policies pertinent to that config visible and working.

Ewen :slight_smile:

Thanks, I was not aware of that.

Yep - its a new trick for young players. :wink: It had me stumped why things didn’t stick until I figured out the reason for the SELECT button. The way they have implemented it makes it a snack to have multiple configurations for multiple locations and quickly switch between them. Our work laptops travel between 6 labs, each with their own configs and this one feature save us so much time, it’s not funny.

Glad I helped.

Ewen :slight_smile: