Update install stuck at 45% Task, 82.2% In Progress

4/12/2017: No progress installing latest update.
“PC stats.png”
“no progress in hour.png”

This is happening a lot and you can read here in the forums about it. But to get you up and going just kill it.

Take notes about your settings, IMO do not export them as you may import problems once you get the new version up and running(it has been said here)

Then follow the directions CLOSELY here and make sure since you are using Windows 7 and it is 64-bit

I used the two tools provided:
Comodo Removal Tool 2014 (ran once in Safe Mode)
CIS Clean-up Tool (ran twice in Safe Mode per the readme file)

I had about 9/37 system that did this too and just running the two removal and cleanup tools worked like a charm. Make sure you download the correct version ( and then pay close attention.

I only wanted the Firewall, not sure if that’s all you want too. In case you do, make sure that when you are installing the newer version that when you see these steps in the below screenshots that you “uncheck” the programs you do not want. In my case I just wanted the Firewall so I unchecked GeekBuddy and Dragon

and then

Once installed go back and check your settings list against the new version and adjust accordingly. Hope this helps

Hi EricRatliff,
In order to investigate, we will need log file that can be found in following format under system’s temp folder:



This can help us investigate problem further.


Thanks swatbat2142 and umesh. I think I lost the chance to save my settings, because I rebooted to stop the install instead of clicking Stop. But, I do have the log file that umesh requested.

On reboot, CIS did not automatically launch, and the troubleshooter could find no problems (as always). But, I can manually start CIS pro 10. It now always needs manual launch on boot. I got this notice about a service not starting:
“no system event notification cropped.png”
Also, my desktop looks changed. All windows now have sharp corners.
“firefox menu weird.png”
“transparancy & rapaint problems.png”
In addition, the little window that says ‘Secure’ does not appear, even thought CIS main window appears.

I would redo the whole thing again so it goes in cleanly.

Remember, uninstall using the Windows Add /Remove, then reboot and go in to safe mode

Use the Comodo removal tool, then reboot back to normal desktop

Install Comodo.

So far from what I am seeing is the default settings are just fine. There may be one or two to set, but if 98% of the work is done then what’s 2% of work to do. I am finally down to 7 more systems out of 37 so I can speak of the removal tool is a game changer and the way to go.

Thanks swatbat2142,

Not sure what “the Comodo removal tool is”, perhaps it is Revo? There seem to be many old removal tools.

I tried removing with add/remove programs
-uninstall Malware Bytes
-uninstall CIS, reboot
-uninstall Dragon
Then install CIS again.
Still square corner windows, no automatic restart of CIS warning, but then it seems to start anyway. Getting dejected.

From this guide. Comodo Forum you can use both the removal tool from here and then this one.

If you follow the guide that futuretech linked in step 2, but read the whole thing before proceeding.

First download the tool
Second, download a new fresh correct Comodo (If you just want the firewall scroll down and you will see “setup” and there is a list of Comodo’s. Get the one that says “Comodo Firewall”)

Save both of those items to your desktop

Uninstall Comodo via Add/Remove (DO NOT use Revo)
Reboot in to Safe Mode
Use the tool
Select option 1, then enter. Select option 2 then enter. Then select option 9 to reboot
Now back at your desktop normally, install Comodo and follow install items; beware of the added software which I showed pictures earlier