update firewall

I am using version 5.5.195786.1383.
Several times now I have had a popup about a firewall update. Each time I have updated my machine, running Windows XP Pro SP 3, many of the programmes will not work - in particular restore, and turn off computer - others say they can not be accessed.
I have tried the update 4 times with the same results and have to go to restore in safe mode.
What’s the problem and how can I correct it?

What do you see? Do you see a Comodo second shield in the systray or do you see a second Comodo shield in the systray with a balloon message saying there is an update?

Once every Windows session you will see the second Comodo shield for a max of approximately 10s. It is then just checking for an update.

I get a shield with a balloon message for about 10 to 15 seconds is I do nothing. It says there is an update. And if I do the up date there is trouble - my original post.

I need more information to know what is going on. Can you explain in more detail what is going on that programs are not working properly anymore? Can you show screenshots of D+ logs (View Defense + Events) and Defense + Rules (can be found in Computer Security Policy).

Is system restore effected? Does it not work?

Why it keeps on saying there is an update I don’t know. Try running Diagnostics and see if that fixes it.

Sorry to be so long getting back to you, had to be out of town yesterday.

The screen shots you requested are attached.

When I have installed the update then nothing works, and I can’t get on line. The only way to turn off the machine is with the power button.

Restore does not work. The only way to get to a restore point is to turn off the machine as above then start in Safe Mode, then restore works from Safe Mode.

Diagnostics said there was a problem and repaired it. That did not help.

If I check for updates myself it says there is one, but if I install then the same problem as with the popup balloon.

[attachment deleted by admin]

Same thing here: “An update is available” with the second “Update” icon displaying in systray. I have the latest version: 5.5.195786.1382, Firewall only, free edition.

I have ignored it so far as I know I have the latest version.

Update process was a 2-step process as noted at the top of the forums.

Options listed above are not needed as I have not run it yet. Diagnostics requested I run it as an administrator ??? (currently in limited user account, never happened before) along with password request. Password request is normal as I have the firewall password protected. Diagnostics did not report any problems.

Running XP Home Edition SP3 P4 2 GB RAM, Avast! 6.0.1203 Free.



After 1382 there was a minor update that will update CIS to 1383. If CIS still reports 1382 you need to run the updater one more time.

On a sidenote: all binaries will have the 1382 version number.


I will update as soon as I see such an update posted on your website.

Thanx for the info.


XP Home Edition SP3 P4 2.8 2 GB RAM Avast! 6.0.1203

The update to 1383 is already there. If you are looking at the Release Notes page then you may not get the proper information as it is notoriously behind.

Just check under More → About for the version number and when you see it is still at 1382 then simply run the updater and reboot afterwards.


Updated to version 1383 w/o any problems.

Thank you for the information. I checked and saw there was a later version on the forums.

Apparently the newest updater (may) automatically update(d) the firewall by downloading the files first, so there was no need to download the files, as before, the most recent update to version 5.5.



XP Home SP3 P4 2.8 2 GB RAM Avast! 6.0.1203 Free