Update failure

Hi guys,
I’ve only had Ice Dragon for a couple of days. I’m trying it out as I started having problems with Pale Moon.
Anyhow, I keep getting a message about an update available however once I’ve downloaded it and hit restart all I get is a pop-up that says ‘IceDragon update failed (Installation error)’
I’ve tried 4 times now with the same results. Any advice would be appreciated.
Thanks in advance.
TjRjn

  • MS Windows 10 Home (64bit)
  • Avast security

I’m seeing the same problem on XP, trying to update from CID 42/25 to the latest version.

The update on Windows 10 worked fine for me, but keeps failing on my XP box.

Same here. I am running 42.0.0.25 on XP, IceDragon downloads the update, I click “restart”, then it hangs and fails after a while. On the Comodo IceDragon homepage, the download link (for v44, right?) offers me to download to V40.x.x.x). In the task manager, I see restart_helper.exe is running. When it has failed, I restart CID and it will return to download the update again and again.

Download the installer of v44 Ice Dragon v44 is now available to download and run it. Or lift the installer from the Windows Temp folder and run it. That way you circumvent the updater process from within the browser.