Update fails if you have had a proxy set then removed it [189]

hi
i previously reported this problem that comodo can not update directly but it updates if i set up proxy bfilter on local host and set up comodo to conect trough the proxy on local host.
unfortunately my report was left with no results :frowning:

now i have the same problem on other computer

i set up comodo to connect trough a proxy on another computer for a while , then i changed my mind and killed the proxy .
then comodo sayed “failed to update” when i try t update virus data base,
then i set up comodo to connect directly , but it again sayed “failed to update”

and now it updates if i set proxy bfilter on local host and set up comodo to connect trough this local proxy.
and this mess with proxy settings is only for updating virus data base , updating of the product is ok.

i think this is very serious bug
and i am afraid that comodo team keep neglecting it .
i hope it will be fixed as soon as possible
thanks
best regards

Not quite clear from your report that you have tried setting up a proxy under more ~ preferences ~ connection?

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

Mouse

ok , you are right - i should make more clear bug report
but i am not very fluent in English and i have no much time too …
and yes it is very difficult to reproduce the bugs …
thats why i report this bug again , because i found it in more than one computer
this is my humble way to help - as much as i can.

any way i thing i found more information for the problem:
i deleted the registry value UpdateURLS (UpdateURL is still here ) and restarted the computer , and
then the update seems to work ok now . (deleting of UpdateURLS works only after restart)

UpdateURLS appears only after setting a proxy and does not disappear after removing the usage of proxy
and it seems that virus database update works ok without proxy if there is no UpdateURLS value.

so it seems that the problem is in UpdateURLS registry value .

thanks

Best regards

Thanks for the extra info. If you draft a bug report in standard format we will be very happy to help you with any English problems.

We would very much appreciate it if you would.

Mouse

Hello,

I just wanted to know if the bug report had been filled up.

I can only confirm the bug : once you’ve set up an authenticated proxy in Comodo’s preferences, no matter if you uncheck the “use http proxy” check-box, the anti-virus database update will fail. Product update are working fine, but you can’t update the database.

I’ll try deleting registry keys as ialtaparmakov has suggested to do, but a fix would be much appreciated…

NB : I said authenticated but it’s maybe the same problem with an anonymous login proxy. I just remember that I had been searching the forums some times ago, and that I found several users reporting this bug only with an authenticated proxy.

you should delete only UpdateURLS
(note i am not sure about the name of the registry value -
i deleted it and only after that i noticed that update works)
but the value UpdateURL must remain in registry
when proxy was set there is new registry value immediately below UpdateURL
i don’t remember the exact name it was similar to UpdateURL but one or 2 symbols longer

i suggest to export registry key comodo to a file before deleting ,

if something goes wrong the function “diagnostics” in “more” tab will restore default registry settings
but you will lose some information

best regards

I’m having the same issue. Removing UpdateURLS didn’t work for me. The update downloads, but as soon as it finishes downloading it fails. I’ve tried both with and without a proxy server with the same results.

Hello again,

deleting UpdateUrl values didn’t worked for me neither.

I can clearly see Comodo trying to reach old proxy’s IP (15.15.1.1) in “View Active connections”.
I’m wondering where does it stores this value as the registry values related to Comodo’s proxy options are OK (read : empty). If I manually modify them, changes are immediately reflected in “Preferences, Connexion”. ???

This definitely looks like a bug.

I guess I’ll give up until a fix has been published.

PM to Cannadoux sent

Please could someone do a bug report in standard format? We would really apprectiate it.

Many thanks in anticipation.

If this is resolved by restarting the computer after you have turned off the proxy settings it’s a known issue.

Thanks Ronny - does it have a BZ number?

189

TOPIC TITLE
Update fails if you have had a proxy set then removed it


The bug/issue

  1. What you did: i set a proxy and then removed it

  2. What actually happened or you actually saw: message box saying “update failed , try again later”

  3. What you expected to happen or see: message box “virus database is up to date”

  4. How you tried to fix it & what happened: i removed the proxy form the settings of comodo
    but still got “update failed” , then removed registry value UpdateURLS but nothing happened
    then i rebooted the computer and it was ok , on the second computer that i have the same problem
    the problem was there since march 2010 as i remember - and i restarted it many times with no effect
    and only after removing of registry value UpdateURLS and rebooting the second computer worked ok .

  5. If its an application compatibility problem have you tried the application fixes here?:

  6. Details (exact version) of any application involved with download link:

  7. Whether you can make the problem happen again, and if so exact steps to make it happen: set up proxy in
    the settings and then removed it

  8. Any other information (eg your guess regarding the cause, with reasons): seems UpdateURLS does not disappear after removing proxy from settings .

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.163652.1142 , but i had version 3.xxx when i first noticed the bug.
  2. a) Have you updated (without uninstall) from CIS 3 or 4: i cant remember - i tried many things - perhaps i had clean install too ,
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
  5. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =
  6. OS version, service pack, number of bits, UAC setting, & account type: win XP and Server 2003 , sp 3 and sp2 for server , 32 bit , administrator
  7. Other security and utility software installed:
  8. Virtual machine used (Please do NOT use Virtual box):

it seems that the problem is fixed now and UpdateURLS is not a problem any more :))

sorry for delay of bug report

best regards

Thanks for a report in standard format. Moving to format verified. This is already tracked in Bugzilla.

Hello again,

I’m very sorry to say that, but despite having tried numerous restarts, this is not resolved at all.
So now, in order to continue using Comodo Internet Security, I have to fill the “connection/proxy” with an anonymous proxy found on the web…

As soon as I clear the proxy settings, the ‘old’ 15.15.1.1 is back again… For the records, it’s the first proxy (authenticated) that I had to use six months ago, and that never went off ever since.
Whether I restart or no after clearing the proxy settings didn’t changed a thing. And believe me I tried every kind of restart I could…

So in the end maybe it’s no big deal, as I manage to get the updates anyway, but I can’t help myself being disappointed when I see that Comodo is releasing an update just to change a size setting, and that this kind of (old) small bug isn’t taken in account.

No misunderstanding here : I still think CIS is the best suite out there, really, but correcting those kind of bugs would make a big difference to" spread the good word" and advertise non tech users.

Greetings to the team.

That’s new for me, but sounds like a bug…

Hello Ronny,

I couldn’t agree more :slight_smile:

Once again, it’s no big deal, as everything works in the end. I’m just willing to help here.

  • Maybe I missed something with the “restart after turning of proxy”, but I don’t think so.

  • As AlexOD asked me by PM, I’ve also checked the proxy settings in IE, but it’s all clear.

  • I’ve been looking into the whole register for “15.15.1.1” and I didn’t found any match.
    I think CIS is storing this value in a “non-accessible to user” config file.

  • One strange thing too :
    As I said, I have to use now a public proxy (194.254.135.103 on port 80, no authentication) => everything works as expected.
    If I uncheck “Use http proxy”, then CIS tries to connect again to “15.15.1.1”, and not to “194.254.135.103”.

So this means CIS is either keeping the last authenticated proxy, or the first proxy that was given to him (“15.15.1.1” was the first proxy I used with CIS).
Unfortunately, I have no authenticated proxy at my disposal for now to test if CIS will “switch” to a new one or stick with the same.

  • I already tried to uninstall/reinstall with no success. Maybe (probably) I missed some files to delete in “Users” or elsewhere.

I’m sorry if I wasn’t clear enough, but it’s a bit hard to explain :slight_smile:

Proxy config is found here in registry:

\HKLM\System\Software\Comodo\Firewall Pro\Options\Proxy
Reg_SZ ProxyServer

Does it show anything? and following that does “UseProxy” have value 0 or 1?

I already had checked these keys :

If 194.254.135.103 set in CIS, it shows the correct port, server and UseProxy is set to 1, wich seems fine.
If I uncheck “Use http proxy” in “Preferences”, then UseProxy, IP and port are set to 0, wich seems fine too.

The only strange thing is that despite ProxyAuthLogin and ProxyAuthRequired are set to 0, there is a password in ProxyAuthPassword in both cases (proxy in use or not).

I made a backup of the keys and tried to zero the password or to delete it, but each time I go back to “Preferences”, “Connection” and click “Ok” (even if I don’t change anything), a new random ProxyAuthPassword is generated by CIS.

So I removed the password key and rebooted the computer without going back to “Preferences”, and… cmdagent.exe is still trying to connect to 15.15.1.1 to update virus database ???
So it seems this key isn’t the cause of the problem.

I’m using Win7 home 64 btw, but the problem occurred before on another computer with XP PRO, so I don’t think it’s OS related.

Well I guess I’ll have to find another authenticated proxy (or even fake one) to see how CIS behaves.
I’m in a hurry now, so I’ll report back later.