Update fails: Base_End_User_v128.cav / Error: 0x80004005 Unspecified err [M1557]

A. THE BUG/ISSUE (Varies from issue to issue)
Scheduled updates never complete. Am forced to update manually. Updates Websites Database has an error. The log specifies file BASE_END_USER_v128.cav, and gives me the option to copy “Error: 0x80004005 - Unspecified error” to the clipboard.

Can you reproduce the problem & if so how reliably?:
Yes. Every time I have to update. Consistently and constantly for like three months now.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Click the updates button.

One or two sentences explaining what actually happened:
Update failed and continue to fail.

One or two sentences explaining what you expected to happen:
For the update to complete.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
N/A

Any software except CIS/OS involved? If so - name, & exact version:
N/A

Any other information, eg your guess at the cause, how you tried to fix it etc:
I’ve followed the advice in this user’s post, as his issue seemed nearly identical to mine. Unfortunately, the problem re-occurs whenever BASE_END_USER_v128.cav is downloaded.

B. YOUR SETUP
Exact CIS version & configuration:
Version = Comodo Internet Security 8.2.0.4674
Configuration = Comodo Internet Security

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Antivirus - On Access
Auto-Sandbox - Enabled
HIPS - Training mode
Viruscope - Enabled
Firewall - Safe Mode

Have you made any other changes to the default config? (egs here.):
Usually I just run with AV set to On Access and Firewall on Safe mode, with all other modules disabled. But I’ve been trying various things to clear this error.

Have you updated (without uninstall) from CIS 5, 6 or 7?:
Not this time, no.

 [b]if so, have you tried a a a clean reinstall - if not please do?[/b]:
 Yes. As described in my forum post - uninstall, reboot, 2X registry cleaners, reboot, download & install, reboot, same error.

Have you imported a config from a previous version of CIS:
No.
if so, have you tried a standard config - if not please do:
Yes. Just now. It didn’t help.

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 Home Premium SP1 64-bit
UAC = Never Notify
Admin account
No virtual machines

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
Spybot S&D is the only other thing I have on here now. This is an almost 5yr old Dell, so it probably had McAffee or whatever when I got it in 2010/2011. Nothing but Comodo since I removed that.

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
Note: Killswitch.csv is inside the zip archive with the CIS Report.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Thanks again

Hi.
Not to sound ungrateful or anything, but is there any kind of timeline on this?

Should be fixed with CIS 8.2.0.5005 so moving to resolved. If you feel this is not fixed please PM a moderator. Thanks.