Update Error with CIS on Vista [RESOLVED]


I have an error problem with CIS on Vista 64.
I have installed CIS for a long time. A few days ago there was an update. I only registered that there is something new (the update maybe was succesfully!?).

Than a short time afterwards (a few days or so) there come a new update information. I clicked on the system-tray bubble and the update window pops up. I clicked on “next” but in the update process I only get a error 112:
Error 112: Unable to copy file: cfp.theme. Please try again.
The udpdate never starts to download something or do something else. Directly after clicking “next” (now normally the download must start) the error occurs.
I also tried to disable my virus scanner, but it doesn’t helps.
Don´t know what this mean. I try again manually a few times, but it doesn’t work. Also when I start my pc the update information comes always again, but it doesn’t work.

Has someone any ideas??
Thanks for help!


I don´t want to start a poll, but there are only this button to start a topic!?
Sorry for this.

Left next to Poll it say’s [New Topic] That will start a post without a poll.

I’ve read somewhere that other users where having this also, they manualy deleted the cfp.theme file

Should be in the \program files\comodo\firewall\themes folder or else open a command box, go to c:\ and issue a “dir cfp.theme /s” without the quotes to see where it resides.
Could be in the virtual store folder under c:\users.

Thanks for the fast reply.
I will try this now …

Thanks for the advice with the “poll” “topic”.
When I posted the view was (in any way … different). I only see buttons, no text links (like now) and I saw no “new topic”.
Anyway. :slight_smile:

I checked this. The cfp.theme file is located at:
\AppData\Roaming\Comodo\Firewall Pro\Data\TempFiles
On Vista (x64).

But when I renamed it (dont want to copy it) it was only new downloaded and the same error appears again.
If I remember correctly, it is at Vista programs not allowed to write their own program directory (after installing) … or something like that!?
It is maybe such a problem?

→ the forum is buggy!
I posted no 2 things and every time I pressed the button the text was cut of at the half and the word “don” appears at the end. ■■■■!
problems with a apostrophe from dont??


I had the same problem on Vista x64.

This solved the issue for me: Close any running instances of Comodo, run Comodo as Administrator (right click option on its shortcut), run the updater to completion (under misc tab), and then restart Comodo normally.

Hopefully it is that simple for you as well.

Good luck.

Hej nameless.

Really thanks a lot!
This fixed my problem! So it is like I thought. The problem was the access-rights of the directories. But I thought the Firewall is already running with administrator/system rights.

Thanks! :slight_smile:

Thanks a lot nameless86. Your solution of shutting down comodo and running it as Admin worked a treat for me too.

Once again my thanks :slight_smile:

I think the last Comodo Update is totally broken.
I also updated my Windows XP Media Center on my Notebook and this update also shows an error and end in a shut down of CIS. I had to do something else (copy some files and start as administrator to get fully updated).

I think CIS is not ready for the last SP from XP (SP3) and Vista (SP1).

I describes both problems in my blog:

I have searched with the error number “Comodo error-0X80072ee7” …but Comodo search did not returned no result .This comodo search is so uncapable of searching with the error number .I have found the correct thread from the google search instead .

Hi Como23,

Can you please post a bit more details about your setup, OS/version/ServicePack.
CIS version, including the AV database version (Misc or More, About).