Update caused lan to be unreachable by IP address (by netbios name OK)

I’m running comodo on windows 10 with softether vpn and xampp. I have not had any problems until today, when I was prompted to update, which I did. Since installing the update, I was no longer able to browse the lan by IP. However, browsing by NetBIOS name worked OK.

I found this thread by google searching: https://forums.comodo.com/firewall-help-cis/comodo-fw-putty-issue-t121074.0.html;msg869557#msg869557

I followed the instructions and immediately I was able to browse the lan by IP address from a laptop BUT NOT my android phone.

This problem is not just smb file sharing - no protocol passes by IP (web, rdc, everything I tried from my phone). By name works - either by using the network name of the server machine, or by FQDN (via router loopback). I’m stumped and I can’t access file shares from my phone now. I’m not sure yet if other computers are affected.

You probably need to do port forwarding for the web services you are using, i.e. opening ports in the global section of Comodo firewall, and equivalent rules for the listening process/application in application rules.

Thanks, but everything worked fine before the upgrade. After the upgrade, no accessibility via IP. Computer name and local DNS worked, but some things simply require an IP (like android SMB clients, for example). Anyway, I could not find a resolution so I finally uninstalled Comodo. Too bad because I liked it but this was a serious ■■■■ to functionality.