Update Antivirus Database fails at 51% on version 3.14

Just updated my CIS to 3.14.130099.587 with virus database version 3769.

When clicking on update virus database get dialog saying : Failed to update the virus signature database, Please check your internet connection and try again later. CIS is reporting that virus signature database is NOT up-to-date.

Running Windows 7 64 bit. Internet connection is fine, not using proxy server.

Try Where can i download the latest full AV database?. Your AV database got probably corrupted. Did this do the trick for you?

Thanks, that seems to have fixed it. Didn’t try it as it says in bright red for version 3.13 only!

Thanks. I will change that it is for 3.13 and up. When it was written that was added to emphasis it is not working with versions older than 3.13.

I’m having the same problem, right down to the versions, but don’t feel confident enough in my computer abilities to use those steps to correct the problem. Is there any way of doing it without going in and out of safe mode (which I’m not sure I even know how to do on my computer as I’ve never even seen it unless a computer has closed improperly)?

You can use Comodo Database Updater - Unofficial. It will do the work for you.

Thank you. I’ll certainly give it a try. :slight_smile:

I had this exact same problem - version 3.14 failing to update at 51%.

I followed the link to the unoffocial database updater but - I’m sure I must have been missing something very obvious - I couldn’t see any program file to download & run.
There is a zip archive at the bottom of the start post with name Comodo Database Updater v 0.6.zip

However I followed the manual steps, using safe mode, and it worked fine. I then ran a further virus definitions update and it took what I think was longer than usual to get an up-to-date set, but it is now running as normal.


Glad it worked out for you. The database number at the moment of writing is 3863.

I have the same problem. I have uninstalled and downloaded the newest version but its still will not allow me to update. Getting really cheesed off with it. Can anyone help?

You could start by trying one of the two suggestions I made in this topic .