Upated Comodo Now Computer Doesn't Work Properly

Yesterday I got a pop up to update my comodo firewall so I downloaded the update now my computer has practically ground to a halt. I never had any problems before and my computer is fairly good but I get the egg timer for forever on start up. Every time theres a defence alert my computer has a heart attack. Internet explorer frezes sporadically and minimisiming a window is a bit of a gamble. Any ideas? Help greatly appreciated thanks.

Hi Phil, Have you tried removing/reinstalling in safe mode? What i suggest is that you download the version you want to install and save it to your desktop then after disconnecting from the Internet reboot into safe mode and remove the version you have installed and after making sure any active scanning AV/AS software is turned off install the copy you have saved to your desktop. Once you have done that reboot in normal start up mode. Regards HL

Thanks for your help, on starting up my computer again i found comodo didn’t run I got an error saying there was no cfpres.dll file. Apart from getting stuck for about twenty seconds on the login screen my computer is otherwise back to normal. The problem now is I can’t uninstall the comodo because of the missing dll file. So it is trying to run but can’t yet it won’t let me uninstall it or overwrite it with the old version. I just want the old version back is there any way to do this, very frustrating.

Will it not uninstall in safe mode? Have you tried restoring your computer to an earlier date and then uninstalling/reinstalling? Let us know how you get on. :THNK