Unwanted alerts

Try as I may, I am unable to persuade Comodo that it should ALLOW Firefox and Thompson speed dial access. I’ve tried to enter those in Trusted sites and I also tick the Remember box each time an alert comes up, but still I’m pestered with alerts.
Could someone help me to correctly and completely deal with this irritation.

I am not completely certain WHY this is happening, I and many others use Firefox and it is remembered. I think it would be the speed dial access perhaps accessing or using Firefox as a parent application that is kicking this off. I am not familiar with Thompson speed dial access so much. If anything changes or uses a parent app, this could be why you get constant pop ups. It may be an authorization issue as well. Have you tried setting these to allow in component monitor as well in application?