Unknown address goes to Comodo, although not using Comodo DNS

I installed CID, because I liked the description of some of the security enhancements. When I installed it, it gave me three choices: use Comodo DNS servers for everything, use them only for IceDragon, or don’t use them at all. I chose to not use them at all, since I use HostsMan with lists like MVPS hosts, so I can whitelist sites as I so desire; and to not allow DNS requests to potentially be logged at a company I do not know much about.

It is installed, and seems to work fine, once I’d chosen a less dark theme. However, when I enter an address that is unknown, such as dfghsdjkfghskldfjghsdifugwernbviurhbvwknb.com, I get page that says Comodo, and that it does not exist, at the DNS.com domain; which is a Comodo domain. I did not expect this to happen, and it suggests that either Comodo DNS servers are being used; or that domain name searches go through Comodo when a domain is not found. I went to about:config, and looked at all the settings that included Comodo, but found none other than for updates and help. Some things that are nonsense that I type into the address bar result in the currently selected search engine called; which is not unreasonable.

I thus request that if Comodo DNS servers, if they are being used, when not selected, will not be used; or that however this Comodo page is being called, you allow for an option for it to be disabled. Even if only a mistyped domain name gets sent to dns.com, it still seems less private to me, than if I used my preferred search engine by using the stock Firefox.


Hi and welcome CodeLurker,
Please check to see if ‘Malware Domain Filtering (Comodo Secure DNS)’ is disabled.
Found under ‘System Defaults’ in the general settings tab of the advanced settings.

Kind regards.

OK, fine. However, it is deceptive to ask people if they want to use your DNS servers, and when they say no, do so anyway.

Hi CodeLurker,
IMO this is not done to be deceptive, rather I think this is a bug.
I tried numerous re-installs trying to replicate this and I have found it happens every time the portable version is selected.

Kind regards.

For the Developers,
Disabling ‘Malware Domain Filtering’ is not being honoured with CID portable during install.

  • Win 7 32-bit
  • CIS V6.3
  • Select the ‘Portable Version’ during install and then select ‘I do not want to use Comodo Secure DNS’.
    Open the CID and under system defaults ‘Malware Domain Filtering (Comodo Secure DNS)’ is still enabled, it can be disabled from there.
  • I have not tried to resolve this issue, other than re-run the installer a few times to be certain.
  • Screenshots N/A.
  • Note: This is only occurring with the portable version.