Unite's prtw.exe grabs focus in real when run in Kiosk [v6] [Resolved]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?: Probably the focus grab when Unite is automatically logging in/out out can be replicated by removing and re-instating network comms, but the regular focus grab may depend on the Unite service malfunctioning as it did today.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a. Open Kiosk
    b. Using desktop link to folder navigate to Comodo Unite folder
    c. Double click on Comodo Unite
    d. Log in to Unite, and set to autologin. Unite was functioning unreliably on day the bug occurred whether run in or out of the sandbox, logging in and out every so often
    e. Note that both MSN and secure contacts list are available. I tried to communicate but only person online went busy. Message send seemed to work as normal though.
    e/f. Opened manage networks window and left open
    f. Exit Kiosk using Switch to windows, and leaving Unite running
    e. Note when typing that something hidden is grabbing focus every 30 seconds or so. This interrupts typing.
    f. Open Killswitch from Watch activity. Look under cmdvirthost, note that focus is grapped every time an instance of prtw.exe opens
    g. Close Killswitch and re-enter Kiosk. Opem Killswitch and watch unite. Prtw.exe opens every time Unite logs out. This happens every 30 second or so, presumably there ius a server problem
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?: Not a standard compatibility issue.
  • Any software except CIS/OS involved? If so - name, & exact version: Unite version 3.02.0
  • Any other information, eg your guess at the cause, how U tried to fix it etc: closing Unite and network management tool fixed the problem
  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware) Sorry, unable to append diagnostics file as this is currently not working.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.0 Build 2708, Proactive

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: HIPS=enabled, safe; BB=enabled, Limited; Firewall=Enabled, safe; AV=enabled, Cloud scan=on
  • Have U made any other changes to the default config? (egs here.): Global FW rules, and app rules created for FTP server and Bugzilla server
  • Have U updated (without uninstall) from a previous version of CIS:No
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:No
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: Win 7, SP1, 64bit, UAC=on, Admin, Vmware installed but not used
  • Other security/sandbox software a) currently installed b) installed since OS: a)no b)no

[attachment deleted by admin]

I’m sorry, perhaps I missed it but did this same behavior (that of stealing attention) also occur if Unite was run outside the sandbox at the same time?

It’s running outside only at present and there is no stealing of focus. Whether it could be interacting … don’t think so as login/out behavior was occurring before I opened it outside. Will check though.

OK you nailed that one thanks. Will delete. Must have been running it without realising.