Uninstalling Comodo kills my network connection [RESOLVED]

After not using it for a while I decided to try Comodo again. I installed the latest version from the site and everything was working OK. I decided to uninstall Comodo to try another firewall and that’s where my issues began. Once I uninstall and reboot I am unable to even get to my router, let alone the internet. My network connection is dead. Somehow its screwing with my lan drivers. Once I re-install comodo it comes back up (even without a reboot).

BTW I’m running 32bit Vista Home Premium SP1.

What I’ve tried so far:

  1. Followed the directions in the stickied post in this forum and was able to perform all steps except those ■■■■ legacy_* keys that wont uninstall. Tried changing the permissions but it won’t let me even on an admin account. Also wont let me change them in safe mode.
  2. Tried uninstalling in safe mode to see if that helped. It didn’t.

So really I’m either locked into Comodo for what seems like eternity or there’s something I’m missing. I’ve never had this much trouble removing an app before. Anyone have any other suggestions? Thanks.

wow, that’s a teaser. Have you tried uninstalling using something like Revo unistaller? I’m not even slightly suggesting that it will work/doanything different, but it does seem to do a better job (i.e. leaves less debris) of uninstalling progs than just using either the apps own unistaller or the add/remove bit in control panel.

Hmmm I’ll have to try revo. I have it installed but dont use it much. I have a feeling that won’t help much though. I’ve been playing around with it and 2 things seem to kill my connection with comodo installed and running “properly”. Disabling the comodo miniport drivers in device manager, booting with the cmdagent service set to manual or disabled, or removing all reverences to inspect.sys in the registry prevents my network connection from functioning. I have a feeling something is messed up between what comodo sets up and what windows lan setup thinks it needs at the windows networking level. Problem is that I have no real way of telling what’s going on. From my standpoint the files are gone and most registry keys are gone. So it seems like windows is having a problem realizing that its not supposed to be using the comodo drivers anymore.

The ironic thing is that I had a hell of a time getting the firewall to run on vista. It would install but comodo would always report a problem. Installing a beta fixed that issue, but now it doesnt want to let go.

try to uninstall comodo
and try WinsockxpFix.exe

Mantra
does that work with Vista as I think that is what he has (poor thing).

Hey now be nice. I might be a masochist, but I have xp and vista in dual boot and rarely boot xp anymore. Vista has been pretty good to me I guess. I must be one of the lucky ones.

nope it works for xp
but maybe there is a vista version or a similar program

try
run->cmd
Start orb, in the search box type cmd hold CTRL-SHIFT, and hit ENTER. YOu will see a UAC prompt, if UAC is still enabled. Click OK, and you will have a command prompt with admin rights.

Then type

netsh winsock reset and hit enter. should work

Well I managed to fix it, though I’m not entirely sure what I did. What I think fixed it for me was disabling the comodo firewall service in the control panel, rebooting, and uninstalling. Things seem to be back to normal. I figured I’d post what I believe worked for me in case someone else encounters this issue. Thanks for the help.

Thanks for the workaround in your case, houseeg.

Thread will be closed now. If issue returns PM any online moderator with a link to it to open.