Uninstalling COMODO FW problem + cfp.dll issues [SOLVED]

I have so much work to do this week and need internet connectivity asap. I recently installed COMODO to see what it was like, and have had some fairly annoying problems with it since its install. It’s got to the point now where I can’t even use the internet, uninstall Comodo or even reinstall it. I can’t even uninstall in safe mode, or do anything!

When I try and run the program I get “ERROR: Error while loading resources from C:\Program File\COMODO\COMODO Internet Security\cfp.dll. Aborting application”. I get this error when the computer starts too.

I’ve got windows XP 32bit SP3 and CIS 3.5.57173.439_XP_VISTA_x32

Many thanks.


I jsut searched the c: for cfp.dll then copied it back into COMODOs main directory in program files.

It’s working now…

Congrats for solving it yourself… :-TU


I have been reading the posts. Some of how you guys are fixing this is greek to me.
I dwnld COMODO Pro onto my XP Pro sp2.
Now, on the same day I installed COMODO, I also installed AVG free. It is now gone.

HERE is the error I get:
ERROR: Error while loading resources from C:\Program Files\COMODO\Firewall\cfp.dll. Aborting application.
I get this at startup, trying to delete from control panel or trying to use the apps below.

I can use internet explorer (bleh).
I am not able to use Firefox (it times out the window), tweetdeck (firewall blocking), googletalk & digsby (firewall blocking). I am unable to dwnld anything else!!!
I am not savvy with backoffice type stuff within windows (registry, etc)

I have had this prob for over 2 mos & I need it gone.
Thank you for your time.

Hi bettia,

Here is what int80 did with pictures:-

Go in My Computer till inside folder like first pic

C:\Program Files\Comodo\COMODO Internet Security\Repair

Right click on the file cfp.dll select to copy

Then go up one folder so you are in

C:\Program Files\Comodo\COMODO Internet Security

in here on any open space right click select paste

windows will ask you to confirm replacing the the file like in third pic

select Yes and you are done.

[attachment deleted by admin]

I have the same problem, i get an error that says: Error while loading resources from C:\Program Files\COMODO\COMODO internet Security\cfp.dll. Aborting application, but when i tried searching the cfp.dll file, it is not found on my computer. I don’t have C:\Program Files\Comodo\COMODO Internet Security\Repair
on my computer either.
I can’t uninstall or install Comodo, my Firefox is starting to fail. Please, what can I do?
Thank you!

Just for reference. There are two ways of trying to uninstall. One is from Control Panel → Software and the other is from the shortcut under Menu Start. Are both not working.

When the above don’t work open the command prompt: Start → Run → cnd → enter → now a black DOS type of environment starts. Now copy the following including the quotes to the command prompt: “c:\Program Files\Comodo\COMODO Internet Security\cfpconfg.exe” -u . YOu can adapt the paht if you have installed CIS on a different path. Now the uninstaller should start. As far as I know there is no repair function in the installer. You may end up uninstalling and reinstalling Comodo.

well after reading these posts i can definitely sympathize.
i have a similar issue that is not resolved by following any of the above steps.

im currently running xp 64 bit.

i installed comodo internet security.
then uninstalled it as i could not rdp on to any machines and had other issues that i needed to get some settings for before i ran it again.

so i tried a remove program via cntrl panel, rebooted and got the cfp.dll error.
which is weird cause it should have been uninstalled.
i did a search and couldn’t find anything for the missing dll.
so i tried a reinstall and that came up with the comodo is already installed do you want to un-install
selecting yes brings no joy after a reboot.
if i select the unistaller from the start menu the short cut for cfpconfig is missing and is not in the recycle bin
i cant uninstall via safe mode
any and all ideas apppreciated

Try a clean install following this procedure underneath (don’t take out the legay keys as they are a lot of work) and temporarily disable all security programs that are running in the background. Let us know if that helped or not.

Start with exporting your configuration to a folder that is not part of the Comodo folder under Program Files. This way you can restore your configuration after the reinstall.

Uninstall CIS and reboot. Then run [url=https://forums.comodo.com/comodo_system_cleaner_fileregistryprivacy_cleaner/comodo_system_cleaner_116494436_released-t37631.0.html]Comodo System Cleaner[/url] to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See: https://forums.comodo.com/help_for_v3/comprehensive_instructions_for_completely_removing_comodo_firewall_pro_info-t17220.0.html;msg119226#msg119226

Now you should be good to go

EricJH, to you i tip my hat.
to be honest i didn’t think it’d work but indeed it did.
half of the reg keys noted in your fix were not present, i guess that indicative of the partial uninstall that occured.

i also found that uninstalling the legacy key may be achieved by logging in as an admin normally, and setting the permissions without having to go into safe mode or using anything other than regedit.
further more a lot of the folders cannot be manually removed until the registry in culled.
a reboot after the cleaning and no pop ups or errors

again much thanks, not sure if i will give it another go or not yet.
thanks again


I installed just the firewall (same version) and I have the same proplem. I tried copying and pasting the files from Repair, but no luck. Those “thourgh” uninstallers fail, as well. I don’t mind leaving it there, I just want Firefox to work. I’m running x64 Windows XP SP 3. Anything to make Firefox work. Is there a process that comes on that I can kill?

Thanks, T-man

Did you follow the clean install I provided?

I did, but I just re-checked, and found a few ones I missed. Everything is working again, and, while Comodo Firewall will be hard-pressed for a re-download, I am happy with the help. :slight_smile:
Thank you.

I ran into exactly this problem when trying to update my CIS (from 3.5, I think) to 3.9.95478.509.
I run XP Home Edition 5.1 32-bit SP2 (at that time, since upgraded to SP3) on a dual core AMD Athlon 64.

The problem sounded identical, so I was very hopeful that your detailed procedure would fix it, even though I did not find all the files/keys you mention but the problem remained ! However, having been pointed in the right direction by your procedure, I hunted round the system for any other Comodo-related files and keys and deleted them all (there were loads !) At this point I was able to re-inatall CIS 3.9 successfully and thought I had cracked it !

However, now, although I could successfully connect to the physical network (both broadband and analogue dial-up) no connection was allowed to any software application - no website, no email server, no Windows updates, nothing ! All were rejected with “unable to connect” or similar error messages. I was (and still am) convinced that this was some obscure firewall/security/authorisation setting or flag which was preventing access and proceeded to reset all the relevant settings I could find plus running numerous trouble-shhoting procedures (including several MS Fixits) all to no avail. In the end (after 2 weeks of fruitless effort !) I had to resort to restoring an 18 month old copy of my system and the laborious re-building that entailed. So I am now back on the air but still mightily intrigued by what was causing the problem if anyone can throw any light on it.

(By the way Eric, line “oo” of your procedure seems to be a duplicate of line “s”).

Anyway thanks for all your help. It might have worked !

Edit by EricJH: the post now has the quote properly