HELLO, i am wasting a lot of time understandig how to remove Comodo AntiVirus.
The uninstaller coming with comodo don’t remove absolutely the software. Now, after a lot of work it’s seem the program is no more loaded in memory. The trouble is now taht AV is triyng to install again on my machine every few seconds. I can’t work!!!

I tried all… cleaning registry manually, cleaning registry with specific software, but still the windows installer starts and try to install again comodo. Stopping the windows installer service is not useful, i still have a continuus flickering on the screen. It’s the comodo application that try to start the installer service that is stopped.

Support is no giving any answer, i sent 2 mail without any answer. I see there is someone else in this condition but the only answer comodo is giving is to write to tech support.
I appreciate that this product is free, but that don’t means that he can give this kind of problems.

Any help from any one?

No problemo dude… heres how

  1. Comodo destroys the links to WINSOCK
  2. Comodo leaves behind running services
  3. Comodo forces your system to use their problem child CAVEMLSP.DLL, this Dynamic link Library is the MOTHER of all defective DLL’s. it is a wolf in sheeps clothing

Personaly if it were me, I would have offered a Force UNINSTALL within 24 hours of first hearing about this problem… But I have a feeling COMODO does not want to offer any method to uninstall. I have been around for 20 + years and I have been through a lot of BETA’s is a very bad BUISNESS idea to not offer a manual instruction set to delete their mess.
Very irresponsible on their part…

Make sure you make a copy of the REG file.

  1. Delete all references to COMODO in the REG file
  2. Reboot
  3. Down load WINSOCKXPFIX.exe from Major GEEKS web site
  4. Run WINSOCKXPFIX.exe Force it to complete
  5. Reboot.
  6. Go to Services, you will find there is still one service running, change its statis to Disabled.

This will disengage CAVEMLSP.dll from the LOAD up, and also redirect pointers to use WINSOCK in the reg file


if you have any questions please feel free to contact me direct.
Software by khg

Hey politicallyincorrect,

Just out of curiousity, did the version of CAV that caused you (and this new user) grief with uninstalling use the InstallShield installer or Comodo’s custom installer?

I’m only asking so I can attempt to replicate the error condition and see if there is an easier way to remove it through a script (just to help others who may end up stuck like this).

P.S. I don’ t think CAVEMLSP.DLL is the mother of all defective DLLs. I’ve got one from SAP and another from F5 Networks that’ll screw your system seven ways to Sunday - not even a BSOD - just death. No excuse for CAVEMLSP, though.

I hope Comodo are getting on top of this. The worst bit is that this bug is intermittent, as I’ve been able to install and uninstall 4 times on three systems tonight without an issue.

Ewen :slight_smile:

Hey Panic!

I didnt had any trouble installing and uninstalling Comodo either.

I was afraid to uninstall it when I first heard about the problems sometime ago, but I didnt had any single problem…

Luck us! =-)

But I am sure that Comodo team is working hard to avoid this problem in the future… Its seems that is a problem with installshield…

Thanks for your time,



At this point I don’t know, which installer, all I can tell you it was the ANTI Virus available (by link off of COMODO Site) late thrusday or friday of last week

The reason I mention CavemLSP.DLL, it is the Dll that was accessing my hard drive NON stop… When I rebooted in safe mode, deleted the file, my accesses to my hard drive stopped. However I lost all TCP/UDP controls…

According to all the tests I ran, it was the instruction set from this DLL… In looking at CPU activity this DLL was the one calling out to my hard drive and also using about 90 % CPU time for hours, One test ran an hour and a half and my drive heated up to 140 degrees, CPU up 10 degrees… I had to place an external fan on the undercarriage of my lap top to keep it from shutting down… The last time I had to place an external fan on my laptop, iwas with the usage of Spin Rite 6.0 ( that was expected )

Something to note, in the Services area, the Uninstall, leaves two services still running.
According to HiJackThis, 4 Items are loaded accessing the TCP, UDP and TCPPIP…

This is the reason I assumed it was this DLL…
Also, it is a fact, the Install program is changing the registery file, to stop pointing to WinSOCK.
According to Spybot, the correct pointers should point to MSwSock.dll for TCP, UDP and RawIP…

When the install occures, the pointers to MSwSock.Dll are removed and 4 pointers to CavemLSP.dll are then paced in the REG file and remain there even after uninstall…

If I were the coder, I would write the REG file enteries of MSwSock.dll into a file, and restore them at uninstall… I realize Windows XP utility to remove REG entries at best works maybe ( I have had trouble with this myself) , I can’t help but think there is some utility out there which can. M$ does offer a comand switch for RegEdit, but I have had bad luck using it, it does not always work…

I dont know why you have not had a problem… perhaps we can swap TSR lists and HiJackThis logs to see how our systems differ…

Thank you again for your most pleasent feed back

It’s not too hard to force uninstall here…

Reboot into safe mode, go to %windows%\Program Files\Comodo\

delete the antivirus directory

run regedit and delete all references to Comodo (dont forget to back up your reg)

reboot , should be gone.

its no secret that Installshield is letting us down badly.
we already have started our own installer on the CPF, soon we will replicate this for the AV.

thanks for bearing with us.

PS: Guys don’t be too hard on politicallyincorre(ct). The guy has to live up to his name ;-)!


Following link in forums explain the problems and resolutions related to
Comodo AntiVirus un-installation.


Ok, politically incorrect…

many thanks for your help.
I done all you suggest… but still comodo try to start my windows installer service that i disabled.
I never got troubles like this. There is no more “comodo” reference in my registry, there is no more files in my hd with “comodo” references, there are no more running services identified as comodo.

It’s a mess, there is still this ghost flickering on my screen trying to install again “Comodo Antivirus”.
If you know some sorcerer that may help me, please notify it.

Thanks again for help-


I believe (and I’m not just sticking up for Comodo here, they’re big enough and ugly enough to look after themselves.) that what you are seeing is a leftover of the InstallShield routines that were used to initially install the Comodo product.

You know there can be a problem with the install/uninstall routine.
Comodo know there can be a problem with the install/uninstall routine.
Funnily enough, InstallShield (now owned by MacroVision) also know there can be a problem with the install/uninstall routine and have several pages of hints and FAQs on thier website.

I’d recommend that you have a look at www.installshield.com and go through their support notes. The worst bit is that InstallShield themselves admit that they don’t categorically know what causes several of the errors that they document. Cold comfort, I realise, but that’s straight from the installation program developers own website.

I hope you can find a solution at installshield.com.

Ewen :slight_smile:

Hi ceccaste,

         Your problem is not because of Winsock layer as quoted by politicallyincorre (politically in corre(ct)). This is an known bug of Installshield. To corect this

Go to \Windows\Installer folder and search for “Comodo AntiVirus”. The search will list the CAV MSI file. Delete this MSI file which is the real cause for your problem.

I hope this helps to solve your problem.


I would agree with your comment if it were not for the FACT (in my case) CavemLSP.dll took over all my TCP, UDP, TCPPIP… now the last time I checked These items were part of this layer, I.E. this was related to the WinSock LSP, according to SpyBot, the items are placed in the grouping of WINSOCK… so I dont know what to tell you… that area is a little out of my league, but I am very very good at removing Malicious code (not to imply Comodo has this kind of code)I make a very good living from my clients… Malicious code in the sense it is causing troubles, in addition I have helped 6 people as of this date via personal contact via email… So I dont know what to tell you except, my VERY unothordoxed appoach was not as politically correct as the Solution now offered by COMODO, I but I did help resolve the issue for a few folks, PROBONO So. What me worry…

Hi, it sound good. The matter is that i don’t have a windows \installer folder.
the only folder named installer is
C:\WINDOWS\system32\config\systemprofile\Dati applicazioni\Microsoft\Installer
And this folder is empty. There is no more on my disk anything named “comodo” the only file that contains reference to comodo antivirus is an MSI47ccd.log file in my temp directory that is generated every time installation try to start.

My only way to work is disable “windows installer service” and wait few seconds every time that comodo installation starts and stop because the installer service is stopped.

What a mess… if i look at the time i am loosing for this probly it will be better to buy an antivirus.
Thanks to all for your help.


   Have you logged in Administrator account?

   If not you cant see a installer folder inside \Windows folder. And installer folder is a hidden folder.


Yes, but still there is no evidence of Windows\installer. it’s no hide i am sure. i have this directory (one for each account) in C:\Documents and Settings"accoutn name"\Dati applicazioni\Microsoft\Installer. That’s all. Still comodo try to start my windows installer service.
But it’s possible no one in comodo knows wich damned string in my registry run this process?

Ceccaste: Sorry you haven’t been able to get this resolved. I’ve forwarded your issue to some of our developers, and hope that they’ll be able to give you an answer within the next day or so. Next time around, pls send us an email at support@comodo.com as well.

(Edit) Just saw that you sent an email out to support. I’ll chase it down.

I came across with this problem and managed to resolve it by:

  1. reinstalling CAV
  2. rebooting
  3. uninstalling after the reboot

Hi Ceccaste,

  1. Download and install the Windows Install Clean Up
    utility using the following link

  2. Choose Start > Program > Windows Install Clean Up to start
    the Windows Install Clean Up utility.

  3. Select Comodo AntiVirus from the list and choose Remove.

I hope this will solve your problem.