Uninstalling CFP 2.4 and Registry issues

I have now restored and investigated the original disaster, and found that my two “Dead” keys were frozen solid. They were owned by a current user who originally (but no longer) had administrator rights. But more significant, nobody had any read or write authority, hence the registry could not be purged for a fresh installation. I tried removal as “Administrator” in Safe Mode and a few dozen more keys became dead - not a good way to gain extra control !!! I now find that most keys have “permissions” giving everyone “FULL Control”, but some were restricted to Myself and SYSTEM, and these could not be touched by “Administrator”. Another weird fact - some keys are owned by “BUILTIN\Administrators”, and others by myself - is this why some people include a total re-install of Windows as part of the annual spring clean ?

I fixed my problem with Registrar Registry Manager Lite Edition, version 5.51.
I selected
HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall
Then “Del” key or “Edit Menu > Delete”, and it all goes away.
The first one is free !!! This is “Free Trial” which expires after 21 days.

I now find RegEdit can repair as below - it is unfriendly but it is free.

Run RegEdit and select
HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall
Edit Menu > Permissions
Optional : Select yourself in list of “Group or user names”
Check box for “Full Control”, Click “Apply”
Click “Advanced” button
Advanced “Owner” Tab :-
Check box to “Replace owner on …”
Select yourself in “Change Owner” box
Click “Apply”;
ERROR Warning “Could not …”
Just grit your teeth and Click OK - if it goes belly up you did back up the registry !!!
Advanced “Permissions” Tab,
Check “Replace …” box, Click Apply
Security Advisory - select “Yes” for continue
Advanced “Permissions” Tab - Click on “OK”
Edit Menu > Permissions - Click on “OK”
No longer within any menu. RegEdit still has selected
HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall
“Del” Key, or “Edit Menu > Delete”
and it all goes away.

Do NOT, repeat NOT, trust any tool to export the Comodo Registry keys.
Any “Dead” key without access will not be exported.
Any damage you do that creates a “Dead” key cannot be fixed by import.
Every registry key has “permissions” which may be different from one-another,
this includes which groups / names have what degree of read / write authority,
and who is the owner for this key - and “permissions” are not included in the
*.reg export/import file. The only way to be sure of recovering from total
disaster is to preserve (NOT EXPORT) the whole registry, either by creating
a Restore Point before you chance your luck, or by using ERUNT (my favourite).

I so miss DOS and wonderful *.ini files that gave me control !!!

Thanks for the follow-up, Alan!

is this why some people include a total re-install of Windows as part of the annual spring clean ?
I think probably so. Windows is known for getting cluttered up with useless junk of all sorts and types. Virtual dust-bunnies and whatnot. :(

My guess is that it (Windows) really can’t handle the change in permissions for the users in question. Once a user has Admin rights, they probably always need to have Admin rights. Might not be that way in theory, but we should all realize that when it comes to complex computing issues, the hopes of “theory” are frequently dashed on the harsh rocks of reality.

LM

so I had the huge problems uninstalling this tool. I used the uninstall option, cleaned the registry and filesystem but still my network connections didn´t work. so finally I found a tool LSP-Fix - a free program to repair damaged Winsock 2 stacks that repairs my winsock settings and after reboot everything worked fine again