Uninstalling and installing the new version with Problems


There is a problem in uninstall and installation of the new version!

Run the command bash /var/cpanel/cwaf/scripts/uninstall_cwaf.sh but the option COMODO WAF is still available in WHM/cPanel. Not completely removed!

Looking at the directorie /usr/local/cpanel/whostmgr/docroot/cgi there are still files of the plugin:

  1. cwaf_catalog.cgi
  2. cwaf_main.cgi
  3. cwaf_sharedlib.pl

Can I remove the files manually?

And when you try to install again the new install ‘waf.comodo.com/cpanel/cwaf_client_install.sh’ you provided I get the error:

Verifying archive integrity…Error in MD5 checksums: dbcc9807d3f6c60cf1e49ba4f1a55e6f is different from 0783fa463f1f043a9c1834a1f991acb4

How do I completely remove the plugin and reinstall it again using the new version?

I can confirm the same problem plus the WHM WAF interface didn’t even mention there was a new version available. I’ve uninstalled and can’t install new :frowning:

I removed the files manually, but the option ’ Comodo WAF ’ still remains in WHM.

/usr/local/cpanel/whostmgr/docroot/cgi i removed:

  1. cwaf_catalog.cgi
  2. cwaf_main.cgi
  3. cwaf_sharedlib.pl

After removing the files, downloaded the installer again and now the installation occurred successfully!

But now there are 2 options in the plugin in the WHM, as the image below:

How to remove one of the options?

Still no joy for me even after removing all those files…

Verifying archive integrity…Error in MD5 checksums: bdf0ca78cc9b78117956e66662760d6d is different from 0783fa463f1f043a9c1834a1f991acb4

You downloaded the installer again?

Hi Yah,

I’ve had to do a locate on anything and everything cwaf, then delete them manually. Restart apache, go to whm mod_sec plugin and reset to default config. restart apache. Then download installer again, tried to install and nothing :frowning:

So again double check that I hadn’t missed any files, downloaded the install script again and viola it installed, updated rules, added in my exclusion list saved & then restarted apache - held my breath and so far it looks like everything is working okay with logs showing the rules blocking.

Happy camper again

To fix the problem of the image:

if you are using cPanel, simply edit the /var/cpanel/pluginscache.yaml file and remove the following lines, leave and re-enter in WHM. Ready problem solved

      - any
    cgi: addon_cwaf.cgi
    icon: ''
    showname: Comodo WAF
    tagname: ''
    uniquekey: comodo_waf

I uninstalled a previous version as it prevented Awstats from updating. After installing the new version I get an error when updating the rules:

[attachment deleted by admin]

Please see my comments:


Seems new rules is not compatible with your system. Could you please provide Apache, mod_security and cPanel version do you use?

This specific server runs Apache 2.2.24, mod_sec 2.7.2 and cPanel 11.40.1 (11).

We recommend you update mod_security to last one. This can be done with help of EasyApache in cPanel.

To start update of mod_security select from left menu “Software”->“EasyApache (Apache Update)”

Now you can press “Build Profile Now” to update your current Apache configuration, or “Start Customizing Based On Profile” if you want to add some modules etc.

Build will take some time. After build all your Apache modules will be updated to last version.

Is this a recommendation or a prerequisite?

If you want to use Comodo rules, it’s a prerequisite, because our rules are not fully compatible with mod_security 2.7.2.