Uninstalled and now I can't reinstall

Hello. I 'm using comodo firewall for a while, and I find it very good. (L)

On to the problem…
I had installed and after the upgrade prompt, I decided to uninstall and do a fresh install.
(While I had I did upgrade to Windows XP SP3 RC2 with no side effects!)

After uninstalling-rebooting I tried to install, but I couldn’t. The same with the old version.

The installation prompts I get are:

  1. “In case you… 3rd party…firewall…continue?” :-TU
    It installs kernel drivers…Press “Finish”

  2. “Are you sure…clean?” :-TU
    And then Bang!!!

Whatever options I choose during the install, after the prompt about scanning my system,
it shows something like I aborted the installation.
3.“Problem with deleting the shortcuts. Please kindly delete the shortcuts manually.” and under this message box it says “Rolling back 100%…”

What is going wrong? How can I get past this situation?
Is this a bug? Please help!

See here.


Well I have done everything I read in this message in order to remove it, but it didn’t work!

Are there any other suggestions?

Do you have a restore point for before you installed the new version? Have you tried Fileassian to get rid of the files? If you do everything listed in the link I sent you it should work.

With all the respect, I 'm not a newbie (:NRD) I removed everything visible (files+registry).

I don’t know if there are any invisible files/folders/drivers/registrykeys.
Maybe this is where the problem I have has the solution. That’s why I ask here at the forums.
And I don’t mean that when a HIPS application has some hidden drivers is bad thing.

Now, I watched the installation folder while it was installing and up until the prompt about the pc being clean, all the files of the firewall were in the installation folder. The moment I dismissed this message, it disappeared.
Does this rings any bells?

Is there any compatibility list except the few applications mentioned in the “incompatsw.ini”? I do have many programs installed in my pc.


And of course I don’t have a restore point. (:CLP)

You should always make a restore point before doing anything. Installing or uninstalling. Do you still have Comodo files installed? When you open up your task manager do you see “cfp.exe” and “cmdagent.exe” running?

I found a strange solution I want to share and I believe that the firewall works fine now.

But this tells me that the installer isn’t very good at what it does.
And i say again that this uninstall-reinstall procedure is something I’ve done many times before, with CPF with no problem in the past.

So, when I launched the installer and I let it unpack the files in “programfiles\comodo\firewall” I saw that it launched the configuration program from that folder if I let it do it’s stuff it would finish by removing the files of CPF.
Then I tried to kill the installer before selecting the last prompt about scanning for viruses, and it worked!
Now I have a working CPF. :THNK

What do you have to say about this?
The installer needs some fixing guys!
That’s what I think.