Uninstall or disable Comodo from boot?


Making a long story short, I installed Comodo with the single boot option when I should have chosen dual boot. The default dual boot is an uncompleted Windows XP install, (the second is the Windows XP in which I did the install.) and when I boot to it I get an error message indicating a file is missing.

I tried just about everything including running a restore when Comodo displays but I always end up with the black screen and the message, “A disk read error occurred. Press Ctrl-Alt-Delete to restart”. Is there a way of disabling or bypassing Comodo on the boot so I can get into Windows and correctly install Comodo?

??? Valentin, the user is talking about CTM not CIS…

The better will be restoring the MBR and get the baseline again.

Thanks for the hello. My problem is with CTM. I had read a terrific review of CTM, and since Windows Restgre rarely seemed to have a restore point I was looking forward to using it.

I’ll give the MBR restore a shot. At this point I can’t get into Windows safe mode, so I don’t see that I have any other option.

If the “problem” is on MBR, you won’t be able to even get the Safe Mode.

Dell, If U could get to CTM sub-console at boot-up, see if U could uninstall CTM there. If U could neither rollback properly nor uninstall, the only thing left is as Tech said, restore MBR.

Ha… It seems Valentin is obsessed with CIS !

I will delete my first post sorry.

I tried creating a Partition Wizard bootable CD I created, but the CD wouldn’t boot.

I tried running a 2004 Symantec Recovery Disk that I had. I get this notice that the computer is in the process of being upgraded to Windows and gives me the option to continue the upgrade, cancel the upgrade and start a new version of Windows or exit. Choosing the option to cancel and start a new ones starts the Symantec Recover disk. This eventually gives me the options menu to Rescue files and folders, Check disk for errors and advanced recovery tasks (none of which did anything, because the drives they were showing didn’t include the hard drives). The utilities options looked promising, because one was to edit boot.ini, but choosing it didn’t do anything except spin the Symantec CD. Viewing the partition info came up with a window that had no drives listed. Restore master boot record flashed an empty DOS window.

I thought of trying to install an old Windows 2000, but the hard drive is an SATA, and I imagine it never supported SATA’s.

I tried continuing the incomplete Windows XP installation but got a message saying it couldn’t find a CD-ROM drive! Tried the option of abandoning the incomplete install and installing a new Windows XP. But that didn’t work because setup didn’t find any hard disk drives installed in the PC.

Help! ???

do you have the XP cd? When you computer boots press F2 or what the logo show you to press to enter the bios then press button and then select to boot from XP cd. Here you select to restore you computer to restore from a time when CTM wasn’t installed.

Valentin N

Good morning.

I tried that, but the unfinished install of Windows leaves me with a screen that says "This computer is already in the process of being upgraded to Microsoft Windows. What do you want to do?

  • To continue the current upgrade, press ENTER.
  • To cancel the current upgrade and install new version of Microsoft Windows, press F10.
  • To exit Setup without installing Microsoft Windows, press F3."
  • Pressing ENTER resumes the installation, but I then get a message saying setup can’t find a CD-ROM drive(!)
  • Pressing F10 starts the process and does gives me a Repair option using Recovery Console. But when I start the Repair process I get a message saying it didn’t find any hard drives installed on the PC(!)

Assuming there’s no way to disable CTM at boot, am I out of options?


can you go in CTM console? If you can try to uninstall it from there.

It looks like I can’t. I have the 5 options to restore system, take snapshot, compact, uninstall and exit. I was hoping uninstall would uninstall CTM, but it just uninstalls snapshots. The kicker in all this is that I love the potential for this software, but I’m caught up in this mess.

The uninstall procedure is always “uninstall to” a certain snapshot, i.e., uninstall CTM files/registry keys, restore MBR and, simultaneously, restore the computer to a particular snapshot (generally, the last one).

Since you mentioned in ur 1st post U had an " Incomplete Windows XP install… ", I think the problem may not be just with CTM. Strongly suggest U reformat ur HDD n reinstall Windows. After successful reinstallation of Windows U then install CTM 2.9beta. ( What version of CTM U used ? )

Few people do get problems when trying to uninstall CTM 2.8 ! Today I tried rolling-back with CTM2.9beta to a snapshot I took a few days ago. It rollbacked in less than 5mins, n everything seemed to work perfectly !

I installed the latest - as of this week - version of CTM.

I realize that it isn’t the CTM that’s the problem but erroneously not choosing the dual boot option when I installed it. I’ve been hoping that someone really familiar with the software and its hooks might have a solution.

I do have a 2nd PC, and I’m wondering if I remove my HDD and convert it into an external drive readable on the 2nd PC via USB if I can remove CTM from that HDD and avoid having to reformat and reinstall the years of applications on the drive. Any thoughts on this?

Which version did you install?
Without CTM running, with version 2.8 you can only get the baseline (before installing).
When version 2.9 you can only get the latest snapshot (current state).

“Dell”, in ur case I think there are only two things left for U to do :

1/ Try restoring MBR with ur Windows set-up disc (which if U could do successfully is the same as uninstalling CTM). That means putting ur Windows installlation set-up disc on ur DVD drive n choosing it as ur Only option in boot-up setting in Bios (disable HDD boot-up option), then try restoring MBR from Windows installation disc.

2/ U may take out ur HDD from the troubled machine n connect it to ur other bootable machine as a slave drive, when U get into Windows U copy all important data/files n back them up on another HDD. (Then U may put the unbootable HDD back n do a fresh Windows installation.)

Did U try uninstalling CTM at boot-up sub-console ? (press ‘Home’ at boot-up right after Bios check-up) I think uninstalling CTM works better on boot-up sub-console !

The boot-up console didn’t give me the option to uninstall CTM. I was unable to restore the MBR due to the fact that I’ve got the unfinished install, so I’ve got to go with option 2. The Dell came with restore disks rather than a MS Windows XP CD, so I’m hoping I can essentially start from scratch once I’ve xferred the files.

Thanks, James321888.