Unformatted / Encrypted Hard Disk drive never turns off [Issue: #258]

Unformatted / Encrypted Hard Disk drive never turns off after x minutes without access

The bug/issue

  1. What you did: Using Comodo Firewall
  2. What actually happened or you actually saw: I have a 500 GB USB Hard Drive connected to my PC, it’s encrypted with TrueCrypt. Approximately every 5 seconds the LED of the drive is blinking once and the drive never goes into power saving state.
  3. What you expected to happen or see: After x minutes without access, the drive turns off
  4. How you tried to fix it & what happened: Uncheck ‘Disks’ under D+ ‘Monitoring Settings’ > ‘Objects To Monitor Against Direct Access:’ (No success)
    D+ ‘General Settings’ check ‘Deactivate Defense+ permanently (Requires a system restart)’ > restart (No success)
    Disabled ‘COMODO Internet Security Helper Service’ and ‘COMODO Internet Security’ via msconfig > restart (Success)
    Mounted the Drive with TrueCrypt (Success)
  5. Details (exact version) of any software involved with download link: TrueCrypt 7.0a TrueCrypt
  6. Any other information you think may help us:

Files appended

  1. Screenshots illustrating the bug: here.
  2. Screenshots of related event logs or the active processes list: here.
  3. A CIS config report or file. here.
  4. Crash or freeze dump file: N/A

Your set-up

  1. CIS version & configuration used: Comodo Firewall 5.0
  2. Whether you imported a configuration, if so from what version: -
  3. Defense+ and Sandbox OR Firewall security level: D+ disabled, FW Custom Policy
  4. OS version, service pack, no of bits, UAC setting, & account type: Windows 7 Ultimate 64bit, UAC active, Administrator
  5. Other security and utility software running: NOD32 Anitvirus
  6. CIS AV database version: Not installed

Thanks for using the standard format and for a well described bug. If you wouldn’t mind, please could you add screenshots of your event logs (covering the boot period) & the active processes list when this problem is occurring.

A CIS configuration report would also be helpful but is not essential

Many thanks


The system events:

The active processes:

Resource Monitor:
the unmounted I: drive http://dl.dropbox.com/u/9065323/Comodo/resourcem.jpg
the mounted I: drive http://dl.dropbox.com/u/9065323/Comodo/ressourcem_mounted.jpg

Configuration report:

Thanks Heimer, that’s very helpful of you.

Now forwarding to verified bugs.


Still not fixed in 5.3.174622.1216 :-\