Unexpected behaviour when entering "services" in cmd.exe

A. THE BUG
Can you reproduce the problem & if so how reliably?:
Me and one other user has reproduced this bug. It is constant.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Open cmd.exe
2: Enter “services” and press Enter.
One or two sentences explaining what actually happened:
Please see attached screenshot.
One or two sentences explaining what you expected to happen:
Nothing actually.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
N/A
Any software except CIS/OS involved? If so - name, & exact version:
No
Any other information, eg your guess at the cause, how you tried to fix it etc:
N/A

B. YOUR SETUP
Exact CIS version & configuration:
CIS 10.0.1.6258
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
All.
Have you made any other changes to the default config? (egs here.):
No.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
No
if so, have you tried a a a clean reinstall - if not please do?:
N/A
Have you imported a config from a previous version of CIS:
No
if so, have you tried a standard config - if not please do:
N/A
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 x64 Version 1703 (15063.540)
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
No

I have same situation, the error appears after a few seconds.

can you guys check again with version <10.0.1.6294>? thank you.

Try it with the command: Services.msc and also check the Path in the System Environment Variables

The cmd opens in the User path and unless the System32 and/or SysWOW64 folders are in the path, it won’t work. Numerous software packages alter the Path in the variables

You’ll probably find if you change the cmd screen to one of those folders that the command services will work

  1. The issue remains after latest update.
  2. services.msc works well and opens Services Control Window.
  3. User path is: %USERPROFILE%\AppData\Local\Microsoft\WindowsApps;d:\Program Files (x86)\Nmap;C:\Program Files\Intel\WiFi\bin;C:\Program Files\Common Files\Intel\WirelessCommon
    System path is: C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;d:\Program Files (x86)\GNU\GnuPG\pub;d:\Program Files (x86)\WinMerge;D:\Program Files (x86)\Microsoft SQL Server (x86) (x86)\90\Tools\binn;C:\Program Files (x86)\Common Files\Acronis\SnapAPI;C:\Program Files\Intel\WiFi\bin;C:\Program Files\Common Files\Intel\WirelessCommon;c:\Program Files\OpenVPN\bin;D:\Program Files (x86)\Skype\Phone;d:\Program Files (x86)\GnuPG\pub;;d:\Program Files\Process Lasso;

“services” command works OK when no CIS is present in the same system. Also it works when started from SysWOW64 folder. Anyway it’s strange why guard32 module prevents to automatically find “services” in SysWOW64 folder when CIS is active in comparison with clean system.

I see that neither the system32 nor the SysWOW64 folder are in your User path, which is where the cmd opens. Try adding them and moving them to the top of the path list, then reboot and test it

It works on my system (Win10 64) after changing the path, then back again. As to why CIS affects the path, I have no idea, unless it it something to do with its inherent protection?

Could you please let me know why I should add system folders in user path variable? They was not there from the begininng.
By the way system32 is in system path.

Also I just checked a clean installation of Windows 7 x64 Ultimate:
User path: no parameter at all.
System path: %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0
There is no SysWOW64 also and the whole path is pretty the same.

Also there is no need to add SysWOW64 into the path according to MSDN.

Once again: the problem is not observed on a clean system. The problem is observed after CIS installation only. The problem is reported by different users. So please fix it!

Why are you trying to execute services.exe when it is already running with guard64.dll loaded in its process space? Are you confusing it with services.msc? You can’t even run services.exe even wihout cis installed as it will immediately exit upon launching which is why it won’t be listed twice in task manager.

OK, more news, so path variable is not an issue. Good :slight_smile:

Exactly. Why I see an error in this case? Why the behaviour differs from what is observed on a clean system?

Hi, gjf.

Thank you for your post. The issue is under investigation. We sent you a letter in personal message. Please, check it.

Kind Regards,
Sergey.