Under CIS, how do you tell which version you have?

I have the Comodo Internet Security (CIS) free version. Qiuestion: How do I tell which
software version number I have?

Windows XP Home Edition Service Pack 3 with all security patches installed.

Running in a hardened, unprivileged account for security reasons.

Dell Dimension 2400 desktop.

Verizon budget DSL.


Miscellaneous | About

ps. welcome to the forum!

I am very unhappy user. I am also using the Comodo Internet Security Free edition.
I am using Vista x64 with Avira Anti-Virus running.

The system was working fine until a month ago and has now stopped updating completely. My Defense Plus module tells me there is an error. and my updates have stopped working. The diagnostics don’t work - telling me that framework.dll has an error and when I try to uninstall CIS I am told that cfpconfig.exe has stopped working.

When I go to Miscellaneous/About - my version number is blank.

Any help would be appreciated.

Thanks - JakeS

what are you running in CIS (av, firewall, d+)?

Sorry - I haven’t been back to the forum in a couple of weeks. I am still frustrated with this problem.
I had been running the firewall and defense +, but the defense+ started telling me it couldn’t update.
Then when I tried to run the diagnostics, CIS told me that framework.dll wasn’t correct even though it had been running on my Vsita Home X64 system since I origianlly installed Comodo months ago.
Now the entire program has gone in the tank and I am getting messages that CFPconfg.exe is unable to run.

At this point I would love to run a clean install and start over, but I can’t uninstall the system. i get the framework error when I try to uninstall and the system starts. If I try to reinstall the latest version of CIS, I am told that I have to uninstall first. And of course, I can’t.

Any suggestions would be appreciated.


It isnt a error from framework, the problem is your missing framework.dll in the CIS folder.

Do you have system restore on? If yes you could restore back to when CIS was ok.

(if you need help with system restore just ask)

Can you boot Windows in Safe Mode and uninstall CIS? (then reinstall latest version from normal Windows mode)

Hi Guys… I appreciate the suggestions, but neither works. I should probably provide a bit more info.
I am using a Intel i7/6GB system running Windows Vista Home 64. When I loaded Comodo, I definitely loaded the x64 version and it worked fine for a while. After an update a couple of months ago I started getting a message from Comodo saying, “The Defense + is not working properly”. I have been taking some classes and haven’t had time to devote to this. Every time I do I lose a few hours and have been getting increasingly frustrated. Uninstall from within comodo doesn’t work, I get an error regarding the Framework.dll I mentioned in an earlier post as well as a follow up message saying “cfpconfg.exe has stopped working”. (See attached images)

I am afraid that my Comodo install is completely hosed.

System restore is on, but doesn’t go back far enough to be of any good and trying to uninstall in SAFE mode didn’t work either. In fact, when I tried to uninstall in safe mode, i got no response at all… not even an error message.

I really have no desire, time or interest in reinstalling the OS.
Any Comodo Jedi Masters out there with any other suggestions would be most welcome.

Thanks for your assistance.

[attachment deleted by admin]

Sorry, I’m out of ideas, especially since I have no knowledge in your OS. :frowning:

You could try using revo unistaller to take comodo out (not sure how to do this) and then try to reinstall CIS.

Im just saying this idea!


Thanks Eric… I will check out that DLL and see if it solves my problem.
I will report back.

That DLL is outdated you may need the 3.9 framework.dll

I attached the framework.dll of 3.9 with this post.

[attachment deleted by admin]

Hi Eric,

I appreciate the framework download, but there is still no joy here after placing it in the Comodo directory and rebooting.

Failing any other suggestions, I am thinking I have to try to uninstall using Revo or something similar.
I am still open to suggestions, but am naturally bugged that I have no control over this security software.