Unchecking "use a prediction service" no longer works


I have my Comodo Dragon set up for web development. When I type a word in the omnibox, I want it to request exactly what I type, which will sometimes be an alias in my hosts file or a keyword recognised by my local proxy. So if I type “net” I mean exactly that.

This used to work with the following settings:

  • Uncheck “Use a prediction service to help complete searches and URLs typed in the address bar or the app launcher search box”
  • set default search engine to “http://%s”
    However, since a recent update (I’m now on Dragon, typing “net” suggests “netflix.com” even with prediction service disabled. So “net [enter]” doesn’t do what it should anymore.

Steps to reproduce

  • Disable “use a prediction service” on the advanced settings page. I also have all the other boxes in that group unchecked, if it makes a difference.
  • set default search engine to “http://%s” (add a new search engine for this in the settings)
  • Type “net” in the omnibox and press enter.

Expected behaviour

  • Dragon tries to request “http://net” (this won’t work for you unless you too have a proxy listening for this, so you should see “web page not available”

Observed behaviour

  • “net” autocompletes to “netflix.com” (which might vary for you), other autocompletes I get which you could try are are “com” → comodo.com and “new” → newlook.com.

This does not happen in Chromium (41.0.2261.0) which I have switched to inatead of Dragon for the time being for my work.


I can see why this feature is useful to some users, but please let developers turn it off again! There’s a reason our system is set up the way it is and we use one-word keywords to access local intranet sites.

System info

Version: Comodo Dragon
Plugins/extensions: bug appears even with all plugins and extensions disabled.
Windows version (w/ 32 or 64-bit) e.g: Win7 Ultimate 64 bit.
User privileges: limited (with option to run as admin through UAC)
Chromium (41.0.2261.0, dev channel) does not have this bug.

This is because of a new “feature” that Comodo added to the latest version of Comodo Dragon

Starting from v.36.1, Comodo Dragon provides the 'Official Site Suggestions' feature to display sponsored links for web sites to users when they type matching keywords into the browser omnibox. For instant, you are going to visit “Amazon”.com. Start typing “amaz”, the Comodo's Official Site Suggestions feature will be activated and the user will be navigated to the sponsored link.

There isn’t any official way to turn it off however there is a work around as described by DaEP below (Please note that the file seems to be recreated so you may simply want to delete the contents of the file rather than the file itself and then set it to read only):

Thanks, Sanya. This is the kind of “feature” I’d expect from a toolbar bundled with third-party software, apparently Comodo is now in on that game too.

I’ve deleted the contents of the file and set a NTFS read-only ACL on it - so far, dragon hasn’t changed it back. Fingers crossed, though I may switch to chromium permanently anyway.

Thank you!

I was facing the exact same issue. Greatly appreciate the workaround. :-TU