Unable to upgrade Windows Preview (soon to be Anniversary Edition) [M1875]

A. THE BUG/ISSUE: The Windows 10 Pro Preview, builds greater than 14352, will not upgrade

Can you reproduce the problem & if so how reliably?: Every time, as long as CIS is installed. The installation goes to stage 4. Anywhere between 91 and 96% complete, the system will reset, reboot, and roll back Windows to the previous installation (14352 in my case)

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Run the Windows 10 Preview upgrade/update

One or two sentences explaining what actually happened: As stated in the “Can you reproduce”,
Stage 1, Preparing Windows to upgrade,
Stage 2, Copying files,
Stage 3, Installing drivers, etc.
Stage 4, configuring Windows

One or two sentences explaining what you expected to happen:
Expected the upgrade installation to complete, as it always did previously.

If a software compatibility problem have you tried the advice to make programs work with CIS?: N/A

Any software except CIS/OS involved? If so - name, & exact version: No

Any other information, eg your guess at the cause, how you tried to fix it etc:
To resolve currently, uninstall CIS.
The Windows file from System32 folder, NVSPCAP64.dll, is being run virtually by CIS during the upgrade installation. I have tried adding this as a Safe file, an exception (everywhere), and told CIS to ignore this file and whatever called it.
All this to no avail.

Exact CIS version & configuration: CIS Proactive

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: All

Have you made any other changes to the default config? (egs here.): No

Have you updated (without uninstall) from CIS 5, 6 or 7?: Yes, clean installation of CIS, Clean installation of Windows 10 Pro x64 build 14352.

if so, have you tried a a a clean reinstall - if not please do?: N/A

Have you imported a config from a previous version of CIS: NO

if so, have you tried a standard config - if not please do: N/A

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Pro x64 Build 14352 installed, current upgrade is now 14376,
UAC on (Windows store apps do not run if this is turned off),
Administrator account
No virtual machine

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system: No other security software!!!

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
Always attach the diagnostics file (instructions on how to do this provided here) and the KillSwitch Process List (instructions on how to do that provided here) and put the resulting file in a zip file. Both should then be attached to your post.
Note that additional information may be requested by the processing Moderator.

This section does not apply, as the process is an Upgrade installation of Windows 10.

Does uninstalling CIS, upgrading Windows 10, reinstalling CIS work? That would be my procedure in any case.

Any other information, eg your guess at the cause, how you tried to fix it etc: [b]To resolve currently, uninstall CIS.[/b]
I think his point is the upgrade of Windows 10 may break CIS, but actually stopping the upgrade is something that should not happen.

Please note he is using default settings, so this should not happen.


Fixed with version 10 according to OP. Moving to “Resolved” section.

thank you. Just reconfirmed resolved with build 14905.