unable to update virus database stuck at database version 17787

I’m unable to update the virus database to the current one,
I tried downloading it manually but when I try to import it, I get an ‘unknown error’
and when I run the built in updater it downloads the database but cant install it again ‘unknown error’,

what else can I try?


  • Finn

[attachment deleted by admin]

Go to the Scanners folder in the CIS installation folder and see if there are files that look like bxxxxxxx.cav ((e.g. b0017181.cav) and try deleting them. Does that make a difference.

When that does not help try the following procedure: Where can i download the latest full AV database?.

yes, deleting the "bxxxxxxx.cav " file in the Scanners folder, solved it, (I had to use a tool called “Unlocker” to detach it from the Comodo memory process and therefore being able to delete it as the file was used by Comodo…) after the deletion, I was able to update Comdoo in the regular manner, I pressed the green button update, Comodo downloaded the signatures and installed them correctly.

this issue happened to me 3 times already yet most times it doesn’t happen, I wish I would be able to understand why sometimes it does happen (though rarely)