Unable to update CIS


I would be very grateful if someone could help with this: If I click on “More” and then “Check for updates” in CIS, it says that there are updates and when I click on “Start” it says, within a couple of seconds that the computer needs to be re-started. When I re-start it the version of CIS is the same as it was before (5.5.195786.1383) whereas it should be something like 5.8.213334.2131

How can I correct this problem?

You may just want to uninstall and then reinstall, unless you have very complicated rules. My advice is given here.

Not to go against Chirons advice but if you prefer not to uninstall/reinstall, following the instructions found here has solved numerous update issues and might be worth a try.

Hi Chiron and captainsticks

I thought that I would give your method a try first of all, captainsticks, because I didn’t want all the hassle of downloading CIS again and then uninstalling/reinstalling it. The last time I uninstalled it with a view to reinstalling it, it would not let me reinstall and kept saying it was already installed.

I ml pleased to say that copying the file from the repair folder worked and I have now been able to update it.

Many thanks to you both

Chriscs, thanks for posting back and glad to hear all is working well.